This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 718602 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-03 20:20 EDT by Jóhann B. Guðmundsson
Modified: 2011-12-01 18:49 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-01 18:49:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Native systemd service file for libvirtd (200 bytes, text/plain)
2011-07-03 20:22 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-03 20:20:47 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Jóhann B. Guðmundsson 2011-07-03 20:43:12 EDT
Note that libvirt-guest sys legacy script requires some work to work with systemd

You probably need to put the start/stop section from it into a script then call it from the unit file as in something like.. 

[Unit]
Description=Suspend Active Libvirt Guests
After=syslog.target network.target

[Service]
EnvironmentFile=-/sysconfig/libvirt-guests
ExecStart=/path/to/libvirt-guests start
ExecStop=/path/to/libvirt-guests stop

[Install]
WantedBy=multi-user.target
Comment 3 Daniel Berrange 2011-07-07 10:25:32 EDT
Posted a patch upstream

http://www.redhat.com/archives/libvir-list/2011-July/msg00343.html
Comment 4 Fedora Admin XMLRPC Client 2011-09-22 13:51:25 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2011-09-22 13:53:53 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Admin XMLRPC Client 2011-09-22 13:59:38 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 7 Fedora Admin XMLRPC Client 2011-11-30 14:32:13 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 8 Fedora Admin XMLRPC Client 2011-11-30 14:35:42 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 9 Fedora Admin XMLRPC Client 2011-11-30 14:42:44 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Fedora Admin XMLRPC Client 2011-11-30 14:53:34 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 11 Eric Blake 2011-12-01 18:49:28 EST
Now upstream, for 0.9.8.

commit 4789fb2e4e5bbb9132310a802a90f0ce85ec0016
Author:     Daniel P. Berrange <berrange@redhat.com>
AuthorDate: Thu Jul 7 14:45:07 2011 +0100
Commit:     Daniel P. Berrange <berrange@redhat.com>
CommitDate: Fri Nov 18 16:16:02 2011 +0000

    Add support for systemd init service
    
    This patch adds support for a systemd init service for libvirtd
    and libvirt-guests. The libvirtd.service is *not* written to use
    socket activation, since we want libvirtd to start on boot so it
    can do guest auto-start.
    
    The libvirt-guests.service is pretty lame, just exec'ing the
    original init script for now. Ideally we would factor out the
    functionality, into some shared tool.

Note You need to log in before you can comment on or make changes to this bug.