Bug 718784 - netbeans-platform packaging improvements
netbeans-platform packaging improvements
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: netbeans-platform (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Omair Majid
Fedora Extras Quality Assurance
: Patch
Depends On:
Blocks: DebugInfo
  Show dependency treegraph
 
Reported: 2011-07-04 11:31 EDT by Ville Skyttä
Modified: 2011-10-18 18:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-10-18 18:20:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Various packaging improvements (7.76 KB, patch)
2011-07-04 11:31 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2011-07-04 11:31:42 EDT
Created attachment 511200 [details]
Various packaging improvements

The attached patch contains the following netbeans-platform packaging improvements, let me know if you'd like me to push and build this for devel:

- Symlink to JNA *.so instead of shipping duplicates.
- Build native bits with $RPM_OPT_FLAGS and without stripping.
- Disable empty -debuginfo subpackage.
Comment 1 Omair Majid 2011-09-19 16:11:44 EDT
Please go ahead and commit this to f17. Or if you cant, let me know and I would be happy to commit it.
Comment 2 Ville Skyttä 2011-09-20 15:19:15 EDT
I've committed the patch to master, but did not try to build it because it no longer builds in Rawhide mock for me for reasons unrelated to this patch:

| You are attempting to build NetBeans using JDK 7 (or higher).
| This is forbidden as it may lead to accidental usage of JDK 7+ APIs.
| Either run Ant with JDK 6, or set nbjdk.home=<JDK 6 home> in /builddir/build/BUILD/netbeans-platform-7.0/nbbuild/user.build.properties
| [...]
| If you are sure you want to build with JDK 7+ anyway, use: -Dpermit.jdk7.builds=true

Additionally, it seems that there are some changes in the f16 branch that should be merged to master: Epoch bump and the fix for bug 717151.  Let me know if you'd like me to take a look at merging these two to master.
Comment 3 Omair Majid 2011-09-20 15:34:59 EDT
(In reply to comment #2)
> I've committed the patch to master

Thanks!

> , but did not try to build it because it no
> longer builds in Rawhide mock for me for reasons unrelated to this patch:
> 
> | You are attempting to build NetBeans using JDK 7 (or higher).
> | This is forbidden as it may lead to accidental usage of JDK 7+ APIs.
> | Either run Ant with JDK 6, or set nbjdk.home=<JDK 6 home> in
> /builddir/build/BUILD/netbeans-platform-7.0/nbbuild/user.build.properties
> | [...]
> | If you are sure you want to build with JDK 7+ anyway, use:
> -Dpermit.jdk7.builds=true
> 

Yup, rawhide is using openjdk 7 as the default jdk, and netbeans 7 is not too happy about that. I would like to see what upstream does before using openjdk7 to build it.

> Additionally, it seems that there are some changes in the f16 branch that
> should be merged to master: Epoch bump and the fix for bug 717151.  Let me know
> if you'd like me to take a look at merging these two to master.

That would be great! Any chance you would want to become a co-maintainer of netbeans?
Comment 4 Ville Skyttä 2011-09-20 17:26:29 EDT
Ok, changes from f16 merged, and additionally I took the liberty of forcing the build with JDK 1.6.0 just to get my changes build-tested (it succeeds in my lock mock now).  I did not submit a build to koji yet as I don't know what might be affected by the 7.0 update and I have no way to test it at the moment.  I'll leave this bug open until the changes get built and into Rawhide as packages.

Regarding co-maintainership, I don't think it would make much sense for me to do it at the moment.  I don't actually use netbeans, I just happened to start looking into it a bit when I was about to push a fix for bug 549903 and found problems getting it to build.
Comment 5 Omair Majid 2011-10-18 18:20:04 EDT
I have built netbeans-platform for rawhide.

Note You need to log in before you can comment on or make changes to this bug.