Bug 71880 - kernel panic no init found on boot up
kernel panic no init found on boot up
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.3
athlon Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 19:36 EDT by Serge Naggar
Modified: 2008-08-01 12:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
file generated by the 7.3 update function (51.11 KB, text/plain)
2002-08-19 19:41 EDT, Serge Naggar
no flags Details
screen shot of non-performing nautilus (31.52 KB, image/gif)
2002-09-03 13:05 EDT, Serge Naggar
no flags Details

  None (edit)
Description Serge Naggar 2002-08-19 19:36:55 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.61 [en] (OS/2; U)

Description of problem:
On boot-up with the athlon 18-5 kernel the system crashed.
e2fsck -p did not report any problems on any of the /dev/hda2=/boot, 8=/, or 9=/zx.
I tried `rescue' with cdrom=1 but no result.
I then tried upgrade and got the attached dump file.
 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.not sure
2.
3.
	

Actual Results:  the system continued to crash with the `kernel panic' message.

Expected Results:  normal boot

Additional info:

Friday evening I downloaded the latest 2 sets of errata from rhn [166-07 & 172-07] into /home/scn/download/160-07 & 172-07.
Saturday, as root, I dragged the 2 folders to /misc/rpm/security in preparation of executing the rpms.
I also made changes to Mozilla preferences. I had found that Mozilla would not accept multiple changes to its preferences but would accept one change 
at a time - make a change press <ok> and close the preference folder; reopen the pref. folder ...

I then went to open the terminal window: clicking the icon produced no window, only a movement in the icon. I tried other icons on the bar with the same 
results.
The root window had visibly deteriorated and no longer responding.
I looged out intending to get back in and compltete the errata, thinking that the root window needed a refresh!

Instead of that the system crashed with a number of messages culminating in the kernel panic: no init found try passing init-option to kernel.

Before that the system had said Init cannot execute /sbin/mingetty [repeated about 11 times] followed by
Init 1 responding too fast : disabled for 5 min.

I tried ctrl-alt-del but got cannot execute /sbin/shutdown
the following pair of msg. were repeated at least 6 times.
Other messages were hda: dma-intr: status=0x51 DriveReady SeekCompleteError
followed by:   error=0x84 DriveStatusError Bad CRC
Comment 1 Serge Naggar 2002-08-19 19:41:15 EDT
Created attachment 71504 [details]
file generated by the 7.3 update function
Comment 2 Serge Naggar 2002-08-20 12:07:40 EDT
The more I think about the situation the more convinced I am that the primary problem came from the folder dragging from /home/scn/download/ to 
misc/rpm/security/.
Nothing else would disrupt and even delete files; but I guess `dragging folders/files' might disrupt the order of things.
I did notice that the file manager would disappear/close.

I had thought that the Mozilla preferences problem [which persisted after the errata update] might be a contributing factor.

If there is any testing you might want me to do please let me know otherwise I will try to go beyond it. I will wait a few hours.

You can reach me at: 1.212.794.0058
Comment 3 Serge Naggar 2002-08-20 19:24:02 EDT
any chance of some interaction/communication?
if nothing else so one can avoid getting into this mess again?
Comment 4 Mike A. Harris 2002-08-21 13:03:35 EDT
>Other messages were hda: dma-intr: status=0x51 DriveReady SeekCompleteError
>followed by:   error=0x84 DriveStatusError Bad CRC

This message in general means your hard disk is failing.  Most likely
your data is corrupt.  I recommend backing up your data to a safe
medium, and replacing the drive ASAP
Comment 5 Arjan van de Ven 2002-08-21 13:11:08 EDT
actually it is "bad cable" usually
Comment 6 Serge Naggar 2002-08-23 19:04:27 EDT
I agree that the data was in fact corrupt. 
As this situation has happened to me more than once and on different machines
and hard disks I cannot agree that it is either the disks and/or the cables.

I did have a hd with bad sectors but it couldn't even load rh7.3. I changed that
disk for another and loaded rh7.3.

While this current disk is the same one I had for the last 7.3 crash I have
completely reinstalled rh7.3.
In the process of installation I re-formatted the linux partitions with bad
partion checks - no problems.
Running on this same disk are os/2 warp4 and dos - both with absolutely no problems.
It is thanks to os2 that I could let you know of the rh7.3 fiasco.

For these reasons I do not believe that the problem[s] are due to either the ata
133 ide disks [Maxtor 60 gig; Seagate 40 gig - separate machines] or the
internal cables.

I found that the file-manager [nautilus] crashed consistently when, as root, I
moved sets of directories/files from one area to another or trash.
Most of the time I could re-open it but then came the time when it would no
longer respond, followed by the other icons/applications on the panel also not
responding.
Once that happened = kernel panic and the system would no longer boot.

I think - only my theory - that the dragging/moving/trashing of
directories/files affects other files/data leading to corruption.
As this is root couldn't the data/file corruption lead to kernel panic?

The hd is set as follows: hda = 60 gig; sda = 2.2 gig removable - external
primary:
hda1 = dos0
hda2 = /boot
hda3 = os/2warp
hda4 = extended:
hda5 = dos1
hda6 = os2
hda7 = os2
hda8 = /              ext3
hda9 = /z             ext3
hda10= swap
sda1 = removable 2.2 gig hdd - external - /mnt/sda

Most of the directory/file dragging involved large files e.g., the downloaded
errata files for 7.3 and before 7.2. and other d/l updates.
I now have those specific files on both the external /sda1 /z rather than the
/misc fs.
I was trying to make sense, to me, of the organization of the hd.

Don't you think that there seems to be an excellent case for cause and effect?
and some look see is warranted?

I'll be glad to cooperate and answer questions.
Comment 7 Mike A. Harris 2002-08-23 22:41:25 EDT
arjan, see also bug #72155 which I've asked for additional information
to be attached to that probably will provide useful for determining
the cause of the problem.
Comment 8 Serge Naggar 2002-09-03 13:05:27 EDT
Created attachment 74724 [details]
screen shot of non-performing nautilus
Comment 9 Bugzilla owner 2004-09-30 11:39:51 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.