Bug 71887 - gnome-cd seg faults
gnome-cd seg faults
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: gnome-media (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-19 20:32 EDT by John J. Germs
Modified: 2015-01-07 18:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 16:14:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rest of cat /pro/ide/hdd/* (1.19 KB, text/plain)
2002-08-22 21:04 EDT, John J. Germs
no flags Details

  None (edit)
Description John J. Germs 2002-08-19 20:32:03 EDT
Description of Problem: CD-Player segmentation fault

Version-Release number of selected component (if applicable):


How Reproducible: 

Unknown, Opened the application a few times then it just crashed.

Steps to Reproduce:
1. 
2. 
3. 

Actual Results:

Application "gnome-cd" (process 1225) has crashed
due to a fatal error.
(Segmentation fault)

Running it from a terminal it looks like this:

gnome-cd

** (gnome-cd:1225): WARNING **: Error reading CD header


Expected Results:


Additional Information:
I know this isn't much info, but I thought i'd report it anyways..  :)

I have not been able to play any audio cd's and have not installed an alternate
cd player as of yet... xmms plays mp3's fine..

My System Specs:

Athlon XP 1900+
Soyo Dragon Ultra
Leadtek GeForce4 Ti 4600
512 meg ram
Comment 1 Havoc Pennington 2002-08-21 19:42:50 EDT
Anything in "dmesg" output? Maybe in /var/log/messages?

Can you include output of "cat /proc/ide/hdX/*" where X is the 
drive letter of your CD drive?
Comment 2 John J. Germs 2002-08-22 20:15:39 EDT
Only things pertaining to the cdrom devices look pretty normal:

Aug 22 17:41:45 localhost kernel: hdc: LITE-ON LTR-32123S, ATAPI CD/DVD-ROM drive
Aug 22 17:41:45 localhost kernel: hdd: DVS DVD-ROM DSR-600H 000121a0, ATAPI
CD/DVD-ROM drive

Aug 22 17:41:46 localhost kernel: scsi0 : SCSI host adapter emulation for IDE
ATAPI devices
Aug 22 17:41:46 localhost kernel:   Vendor: LITE-ON   Model: LTR-32123S       
Rev: XS0X
Aug 22 17:41:46 localhost kernel:   Type:   CD-ROM                            
ANSI SCSI revision: 02
Aug 22 17:41:46 localhost kernel: hdc: DMA disabled
Aug 22 17:41:46 localhost kernel: hdd: DMA disabled
Comment 3 John J. Germs 2002-08-22 20:21:32 EDT
cat /proc/ide/hdd (in two parts)

1143352
ide-cdrom version 4.59
85c0 0000 0000 0000 0000 0000 0000 0000
0000 0000 2020 2020 2020 2020 2020 2020
2020 2020 2020 2020 0000 0000 0000 4330
3139 2020 2020 4456 5320 2020 2020 4456
442d 524f 4d20 4453 522d 3630 3048 2020
2020 3030 3031 3231 6130 2020 2020 0000
0000 0b00 0000 0200 0000 0006 0000 0000
0000 0000 0000 0000 0000 0000 0000 0007
0003 0078 0078 0078 0078 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0010 0017 421c 0010 4000 421c 0010 4000
0407 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0100
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
0000 0000 0000 0000 0000 0000 0000 0000
Comment 4 John J. Germs 2002-08-22 21:04:11 EDT
Created attachment 72444 [details]
rest of cat /pro/ide/hdd/*
Comment 5 John J. Germs 2002-08-25 14:59:35 EDT
I reinstalled libstdc++ off the disc and gnome-cd doesn't segfault anymore.

I've had to switch my audio cable from cdrom1 to cdrom to see if the player
works since the interface won't apply changes when changing to /dev/cdrom1 and
it works fine.

I'll look and see if there's a bug listed for that, if not I'll submit one.
Comment 6 Rui Miguel Seabra 2003-01-06 16:35:46 EST
Could this be because we're talking of corrupt cd?
http://www.fatchucks.com/z3.cd.html

I've bought some cds and I'm experiencing this problems for the first time (with
all my other cd's nothing's wrong). One of them is for certain corrupted and the
others are likely suspects due to their editor.


I start getting things like:

hdc: packet command error: status=0x51 { DriveReady SeekComplete Error }
hdc: packet command error: error=0x50
ATAPI device hdc:
  Error: Illegal request -- (Sense key=0x05)
  Cannot read medium - incompatible format -- (asc=0x30, ascq=0x02)
  The failed "Send DVD Structure" packet command was:
  "ad 00 00 00 00 00 00 01 00 08 00 00 "

floating around in dmesg... this in three completely different computers, with 3
completely different cdrom drives.

# hdparm -I /dev/hdc

/dev/hdc:

ATAPI CD-ROM, with removable media
        Model Number:       Pioneer DVD-ROM ATAPIModel DVD-105S 0122
        Serial Number:
        Firmware Revision:  E1.22
Standards:
        Likely used CD-ROM ATAPI-1
Configuration:
        DRQ response: 50us.
        Packet size: 12 bytes
Capabilities:
        LBA, IORDY(can be disabled)
        Buffer size: 64.0kB
        DMA: sdma0 sdma1 sdma2 mdma0 mdma1 mdma2 udma0 udma1 *udma2
             Cycle time: min=120ns recommended=120ns
        PIO: pio0 pio1 pio2 pio3 pio4
             Cycle time: no flow control=120ns  IORDY flow control=120ns
Commands/features:
        Enabled Supported:
           *    DEVICE RESET cmd
           *    PACKET command feature set
           *    Power Management feature set


I'm complaining about the cd's today or tomorrow...
Comment 7 Havoc Pennington 2003-01-14 16:02:14 EST
We'll need a backtrace from the crash to do much here I think.
You should get a "gnome-cd has crashed" dialog that lets you report the
backtrace to bugzilla.gnome.org, then you could link to that bug here. Easiest
approach.
Comment 8 Colin Walters 2004-09-27 16:14:34 EDT
No response from submitter in over 1 year, closing.

Note You need to log in before you can comment on or make changes to this bug.