Bug 718892 - F-15 LXDE: Latest i-bus update broke direct input (Anthy) + Switch ON-OFF
F-15 LXDE: Latest i-bus update broke direct input (Anthy) + Switch ON-OFF
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ibus (Show other bugs)
15
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: fujiwara
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-04 22:36 EDT by nomnex
Modified: 2011-07-08 14:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: ibus-1.3.99.20110419-9.fc15
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-08 14:00:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
ibus displays a separted window for the input (30.39 KB, image/png)
2011-07-04 22:36 EDT, nomnex
no flags Details
Shortcut to swtich ON-OFF does not work (54.12 KB, image/png)
2011-07-04 22:50 EDT, nomnex
no flags Details
input still displayed in a small separated window (17.88 KB, image/png)
2011-07-07 22:47 EDT, nomnex
no flags Details

  None (edit)
Description nomnex 2011-07-04 22:36:46 EDT
Created attachment 511236 [details]
ibus displays a separted window for the input

Description of problem:

ibus (ibus-anthy), to type Japanese in a en_US OS, used to work fine until a recent update. Ever since the update:

(a) No direct input occurs anymore. The input reside in a small window next to or beneath the document window or the input field.

(b) after update the default shortcut selection to swith ibus ON/OFF was gone (the field was empty) any new custom combination are ineffective. ibus cannot be switched ON-OFF as it used to be.

Version-Release number of selected component (if applicable):

IBus 1.3.99.20110630

How reproducible:

Always

Steps to Reproduce:
1. Update to the latest version in the repo
2. Open a text editor and select Anthy
3. Input some letters
4. Try to switch ibus OFF
  
Actual results:

(a) See print-screen: the input does NOT occur inside the document window as it used to be, but in a small separated window

(b) ibus cannot be switch OFF (Only QUIT)

Expected results:

(a) Direct input in the core document.
(b) To turn ibus ON-OFF

Additional info:

ibus is currently unusable for me in this current state. How can I revert to the state prior the update (it was working perfectly?) or what should I do best (use another input method?). I live in Japan and it's a feature I need. Ever since I use ibus, it has always been reliable. Thanks.
Comment 1 nomnex 2011-07-04 22:50:18 EDT
Created attachment 511237 [details]
Shortcut to swtich ON-OFF does not work

Print screen of the (b) ibus cannot be turned ON-OFF with a shortcut (after the update the shortcut field in the preference was empty).
Comment 2 Fedora Update System 2011-07-04 23:58:41 EDT
ibus-1.3.99.20110419-8.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-8.fc15
Comment 3 nomnex 2011-07-05 22:36:33 EDT
(In reply to comment #2)
> ibus-1.3.99.20110419-8.fc15 has been submitted as an update for Fedora 15.
> https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-8.fc15

Link above redirects to:

https://admin.fedoraproject.org/updates/?_csrf_token=ec3b1e3874d023920e6582741e9f0cc5f30cab2b

Looks like this is the correct package

https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-9.fc15?_csrf_token=ec3b1e3874d023920e6582741e9f0cc5f30cab2b

When I pass:

$ su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-9.fc15'

Output:

Setting up Update Process
No Match for argument: ibus-1.3.99.20110419-9.fc15
No package ibus-1.3.99.20110419-9.fc15 available.

I don't have much background with updates-testing procedure. Someone points me to the right direction to install and test ibus. Thanks in advance.
Comment 4 fujiwara 2011-07-05 22:56:18 EDT
(In reply to comment #3)
> https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-9.fc15?_csrf_token=ec3b1e3874d023920e6582741e9f0cc5f30cab2b

It's right but if you would see that page, it shows 'Pushed:' is False.
The packages are not put in the updates-testing repository yet.
Maybe available tomorrow.

> 
> When I pass:
> 
> $ su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-9.fc15'
> 

The rpms are also available:
http://koji.fedoraproject.org/koji/buildinfo?buildID=251620
Comment 5 Fedora Update System 2011-07-06 17:26:54 EDT
Package ibus-1.3.99.20110419-9.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ibus-1.3.99.20110419-9.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/ibus-1.3.99.20110419-9.fc15
then log in and leave karma (feedback).
Comment 6 nomnex 2011-07-07 22:47:48 EDT
Created attachment 511829 [details]
input still displayed in a small separated window

Sorry, but it is still broken.

before the update ibus 1.3.99.20110419.2.fc15, it was working perfectly. after this update, ibus is broken with Japanese input

- no direct input (small input window) (see new print-screen)
- no way to switch it off (the ibus tool bar is permanent. The short cut (now working) to switch it ON/OFF only toggles the bar with either "default layout" or "Japanese") Before, switch off turned ibus off and the tool bar was gone.

I have another notebook running F-15 LXDE. I did not update ibus and it is working as expected. I will check the exact ibus version the next time I turn it on.

What is the full command to roll back ibus to the same version on the other notebook (the version prior the update)? I really need Japanese input. Sorry about that.
Comment 7 fujiwara 2011-07-07 23:12:36 EDT
(In reply to comment #6)
> - no direct input (small input window) (see new print-screen)

I think the state has not been changed since the ibus -2.
If you use X applications, the preedit erea is shown in lookup window.
If you use GTK+ applications, the preedit erea is shown on each application.

> - no way to switch it off (the ibus tool bar is permanent. The short cut (now
> working) to switch it ON/OFF only toggles the bar with either "default layout"
> or "Japanese") Before, switch off turned ibus off and the tool bar was gone.

I think the languagebar is fixed in ibus-1.3.99.20110419-9.fc15 .
The Control + Space key can switch "default layout" and "Japanese"

% rpm -q ibus
ibus-1.3.99.20110419-9.fc15.x86_64
Comment 8 nomnex 2011-07-07 23:38:22 EDT
I have checked the other notebook:

IBus 1.3.99.20110608 Is working

- turn off input method (is present in the menu)
- shortcut to turn off "Control+space, etc." is working
- direct Japanese input is working (no separated input window)

IBus udpdate 1.3.99.20110419-7.fc15 Breaks Japanese input

- no menu to turn off input method
- shortcut not working
- input appears in a small windows (not directly in the document)

Both computer have the same OS. I just did not update the former.

GTK+ app with IBus 1.3.99.20110608 gives direct input, while IBUs udpdate 1.3.99.20110419-7.fc15 changes that (my print screen showing this little window).

Control + Space key does not work for me, If I try another key sequence e.g. Ctrl+Shift+I I can change "default layout" and "Japanese", but that's not "Turn off input method". It's merely the same as "Next input methode" Alt+Shift_R which does the very same.

My computer knowledge is limited as you can read. So if you could you help me to roll back to version prior this IBus udpdate 1.3.99.20110419-7.fc15 (i.e. roll back to IBus 1.3.99.20110608) I could be out of trouble for now. I will just not update, as I do on the other machine.

Thanks in advance.

Ps: (is this the command I am asking to roll back a software "% rpm -q ibus
ibus-1.3.99.20110419-9.fc15.x86_64"?) Shall i pass this command to return to version IBus 1.3.99.20110608? - My apology for so much confusion.
Comment 9 fujiwara 2011-07-08 00:09:11 EDT
(In reply to comment #8)
> I have checked the other notebook:
> 
> IBus 1.3.99.20110608 Is working

I think you mean 1.3.99.20110419-2.

> 
> - turn off input method (is present in the menu)
> - shortcut to turn off "Control+space, etc." is working
> - direct Japanese input is working (no separated input window)
> 
> IBus udpdate 1.3.99.20110419-7.fc15 Breaks Japanese input
> 
> - no menu to turn off input method

Yes, it was removed as expected.
The latest ibus don't have the state of IM engine off.
It assigns the default keyboard layout as one engine and toggle the default input method and the default keyboard layout.

> - shortcut not working
> - input appears in a small windows (not directly in the document)

I still don't understand this problem.
Which application do you use?
Do you enable the check box 'Embed preedit text in application window' when you launch 'ibus-setup' command?

> 
> Both computer have the same OS. I just did not update the former.
> 
> GTK+ app with IBus 1.3.99.20110608 gives direct input, while IBUs udpdate
> 1.3.99.20110419-7.fc15 changes that (my print screen showing this little
> window).
> 
> Control + Space key does not work for me, If I try another key sequence e.g.
> Ctrl+Shift+I I can change "default layout" and "Japanese", but that's not "Turn
> off input method". It's merely the same as "Next input methode" Alt+Shift_R
> which does the very same.

Now the default 'Control + Space' can be changed in 'Enable or disable' text box in 'ibus-setup'.
The trigger key and next input method is different.
The trigger key toggles prev engine and next engine.
The next input method rotates the next engines in the preload engines.

Yes, the latest ibus no longer has the state of IM engine off.
The default keyboard layout would become the similar state of IM engine off.
The latest change can put the keyboard layouts and input methods in the same layer.

> % rpm -q ibus
> ibus-1.3.99.20110419-9.fc15.x86_64

I asked this to check if you installed the latest ibus.

ibus-1.3.99.20110419-2 is available:
http://koji.fedoraproject.org/koji/buildinfo?buildID=246871
Comment 10 fujiwara 2011-07-08 00:18:10 EDT
(In reply to comment #9)
> > % rpm -q ibus
> > ibus-1.3.99.20110419-9.fc15.x86_64
> 
> I asked this to check if you installed the latest ibus.

I mean if the result is ibus-1.3.99.20110419-7.fc15.x86_64 in your env, the ibus is still old and you could update it to ibus-1.3.99.20110419-9.

# yum install --enablerepo=updates-testing ibus
# rpm -q ibus

> 
> ibus-1.3.99.20110419-2 is available:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=246871
Comment 11 nomnex 2011-07-08 01:15:43 EDT
fujiwara, first I want apologize. this is not a bug, it a user misunderstanding. secondly, I thank you for your feedback and your timely answers (Explanation detail interleaved with the quotes) 

(In reply to comment #9)

> > - no menu to turn off input method
> 
> Yes, it was removed as expected.
> The latest ibus don't have the state of IM engine off.
> It assigns the default keyboard layout as one engine and toggle the default
> input method and the default keyboard layout.

From F13 up to the F15 DVD installation, the default ibus had the "state of IM engine off". It was my assumption the update broke this feature. The F-wiki ibus is not up to date. I have also looked on http://code.google.com/p/ibus/wiki/News, but I am not sure to understand half of the changes.

> I still don't understand this problem.
> Which application do you use?
> Do you enable the check box 'Embed preedit text in application window' when you
> launch 'ibus-setup' command?

To make the matter worse, my English knowledge is perfectible. "embed preedit text in application window" make sens as separate words, but it did not as a feature. I don't recall if this option was available on the ibus on Fedora 13. I only recall direct input was working out of the box (but with Abiword), and I was wrongly assuming direct input was the sole alternative. Reading a few times your comments finally rang the bell.

I am located in Japan and it's a perquisite to write (and learn) Japanese. I would probably had not noticed anything if the option "embed preedit..." was turned on by default. Once again, I apologize.

I am relieved to be able to input Japanese again, without anxiety. Thanks to you.

PS I will update the karma on the bodhi page.
Comment 12 fujiwara 2011-07-08 01:40:01 EDT
(In reply to comment #11)

OK, great. Thanks for your test.
Yes, the GUI option "Embed preedit text..." is not available in F13.

I'm gathering the feedbacks about the new feature of the new Control + Space in this week.
Probably I will revert the feature for fedora 15 next week but keep the feature in fedora 16 at the moment as we will have the further discussions.
Comment 13 nomnex 2011-07-08 02:49:43 EDT
Were is the discussion for the feedback (link). I would like to learn more or participate. "Enable/disable" & "Next input" shortcuts made sens with the previous behavior. With new approach (explained in comment 11), the pref. field for a shortcut "enable/disable" seems redundant* (even prone to mistake for old timer users).

*I maybe finally understand the rational; why the field was suddenly blank after updating.
Comment 14 fujiwara 2011-07-08 03:59:16 EDT
Originally the 'Enable' and 'Disable' fields are added besides 'Enable or disable' fields because some IM engines like to have the different hotkeys between disable and enable.

In the new Control + Space, disabled status is no longer used but maybe the 'Enable' and 'Disable' fields are still useful for the debug purpose.

The default layout engine is automatically added. So if you add anthy and pinyin input method engines:
  - Enable or disable hotkeys toggle prev and next engines (the default layout and anthy)
  - Disable hotkeys may be used for the debug purpose
  - Next input method hotkeys rotate engines in the list (the defalut layout -> anthy -> pinyin)

(In reply to comment #13)
> *I maybe finally understand the rational; why the field was suddenly blank
> after updating.

Yes, in ibus -7, I removed the hotkeys in 'Enable or disable' and put the hard-coded Control + Space only but it's fixed in ibus -9 with bug 
718450.

The main purpose of the new 'Control + Space' is to put the input methods and keyboard layouts in the same layer:
http://live.gnome.org/GnomeShell/Design/Guidelines/SystemStatus/InputLanguage

If your graphics card supports 3D, the gnome-shell is enabled by default in GNOME3 and you may be able to install ibus-gnome3 with yum.
https://fedoraproject.org/wiki/I18N/InputMethods#GNOME-Shell
Comment 15 Fedora Update System 2011-07-08 14:00:37 EDT
ibus-1.3.99.20110419-9.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.