Bug 718927 - Lock ordering problem on re-load of direct maps
Summary: Lock ordering problem on re-load of direct maps
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: autofs
Version: 6.1
Hardware: All
OS: Linux
unspecified
high
Target Milestone: rc
: ---
Assignee: Ian Kent
QA Contact: yanfu,wang
URL:
Whiteboard:
Depends On:
Blocks: 732332
TreeView+ depends on / blocked
 
Reported: 2011-07-05 07:43 UTC by Ian Kent
Modified: 2011-12-06 17:59 UTC (History)
1 user (show)

Fixed In Version: autofs-5.0.5-34
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 732332 (view as bug list)
Environment:
Last Closed: 2011-12-06 17:59:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
Patch - fix null cache deadlock (1.04 KB, patch)
2011-07-05 07:43 UTC, Ian Kent
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1723 normal SHIPPED_LIVE autofs bug fix and enhancement update 2011-12-06 01:02:10 UTC

Description Ian Kent 2011-07-05 07:43:20 UTC
Created attachment 511265 [details]
Patch - fix null cache deadlock

Description of problem:

When reloading maps that include a combination of direct and indirect
maps it is possible for automount to deadlock due to incorrect lock
ordering.

How reproducible:
Occasionally.

Steps to Reproduce:
Reported upstream.
I'm not able to reproduce the problem at the moment.

Comment 2 yanfu,wang 2011-10-20 03:32:25 UTC
check patch autofs-5.0.5-fix-null-cache-deadlock.patch apply is sane and as per below comment from dev: 
The problem described by this bug is fairly obvious once the issue is recognised. The fix is not quite so obvious but is a small change and has been verified by the reporter upstream.

Comment 3 errata-xmlrpc 2011-12-06 17:59:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1723.html


Note You need to log in before you can comment on or make changes to this bug.