This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 7190 - smbfs needs smbmount not smbmnt
smbfs needs smbmount not smbmnt
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
6.1
All Linux
medium Severity low
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-21 02:57 EST by Joseph Malicki
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-02 08:44:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Malicki 1999-11-21 02:57:54 EST
With samba 2.0, smbmount should be used, not smbmnt, for autofs.... the
redhat patch to autofs incorrectly changes the behavior to use smbmnt,
which doesn't work when smbmount does.  Removing the last hunk of the
autofs-3.1.3-redhat.patch makes it work correctly.

Since the rpm is built on a system without samba, this doesn't matter as it
won't be included.

But perhaps there should be a separate autofs-samba package for this, that
is built on a system with smbmount installed, so that the automounter's smb
mounting will work without having a dependency on samba?
Comment 1 Nalin Dahyabhai 2000-02-02 08:44:59 EST
This should be fixed with the versions of autofs and samba-client in Raw Hide,
which are slated to be in the next release.  The syntax for my test map is:
tmp		-fstype=smbfs,guest	://samba-server.example.com/tmp

If upgrading to these versions does not fix the problem for you, please
re-open this bug.  I will certainly want to fix it as soon as possible.

Note You need to log in before you can comment on or make changes to this bug.