This service will be undergoing non-disruptive maintenance at 07:20 UTC, 2018-12-14. It is expected to last approximately 30 minutes
Bug 71906 - email sent via "/usr/sbin/sendmail" fails to get sent.
Summary: email sent via "/usr/sbin/sendmail" fails to get sent.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: sendmail (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 04:54 UTC by Douglas Kilpatrick
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-30 08:09:43 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Douglas Kilpatrick 2002-08-20 04:54:25 UTC
Description of Problem:  
Outgoing email fails to go: client spool manager fails to connect to sendmail  
on localhost.  
  
Version-Release number of selected component (if applicable):  
sendmail-2.12.5-5  
 
How Reproducible:  
Very, for me.  Box needs to be networked, of course, and shouold probally have  
a static IP address (its a "real IP" vs. 127.0.0.1 issue)  
  
Steps to Reproduce:  
1. Use mailx to send mail message off box  
2.   
3.   
  
Actual Results:  
Mail message gets stuck in /var/spool/clientmqueue  
  
Expected Results:  
Mail message gets sent.  
  
Additional Information:  
  
Stupid extra dot...  One part of sendmail is apparently trying to connect to  
"hawke.oppositelock.org.:25"  Notice the "." after org.  That dot is all good  
and proper, except that the default install didn't include  
"hawke.oppositelock.org." as a name for 127.0.0.1 in /etc/hosts.  
  
As a result, the client side looks up that name, finds it as my external IP  
address, and attempts to connect to it, which fails (of course) as sendmail is  
not listening on the external IP address by default.  
  
Quick hack to get my email out: added hawke.oppositelock.org. to /etc/hosts.

Comment 1 Charles R. Tersteeg 2002-08-23 00:21:57 UTC
i had this happen on my laptop which gets it's ip via dhcp.  hostname is
specified locally.

my /etc/hosts file looks like this:

127.0.0.1          foo.bar.org foo localhost.localdomain localhost
localhost.bar.org.

note the last alias with trailing period: localhost.bar.org.; i had to add this
to make it work.

Comment 2 Florian La Roche 2002-12-02 15:20:40 UTC
The newest rawhide version should have this fixed with the default setup.
Please reopen if that does not work for you.
http://people.redhat.com/laroche/ also has the newest rpm available.

Thanks a lot,

Florian La Roche



Note You need to log in before you can comment on or make changes to this bug.