Bug 71908 - Installer does not see LVM on raid devices except /dev/md0
Installer does not see LVM on raid devices except /dev/md0
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
8.0
i386 Linux
high Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 74142 (view as bug list)
Depends On:
Blocks: 67218 79579
  Show dependency treegraph
 
Reported: 2002-08-20 01:21 EDT by Douglas Kilpatrick
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-27 16:19:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Douglas Kilpatrick 2002-08-20 01:21:20 EDT
Description of Problem: 
 Low priority, as beta->beta upgrades are not supported, but it might be 
relevant for future versions, so I figured I'd file the bug report. 
 
System (limbo2, basically no updates) set up with two raid sets, one RAID0, 
one RAID1.  Two LVM volume groups, one on the RAID1 set called "Mirror", the 
other called "Stripe".  Many (many) partitions off of each volume.  Root is 
"/dev/Mirror/slash" 
 
Tried to upgrade to Null via "upgrade".  Anaconda claims "fstab contains 
entries that can not be mounted.  Please fix and try again."  At the top, 
anaconda claims that it found root at /dev/dev/Mirror/slash. 
 
The fstab is fine.  I noticed that the installer did not have a /dev/Stripe 
directory, so I commented out all the strip-set partitions and tried again.  
Same result. 
 
Version-Release number of selected component (if applicable): 
null's installer. 
 
How Reproducible: 
Dunno.  This is a pretty wacked setup. 
 
Steps to Reproduce: 
1. Created above messed-up schema with Limbo. 
2. Try and upgrade to null 
3.  
 
Actual Results: 
"fstab contains entries that can not be mounted.  Please fix and try again" 
 
Expected Results: 
successful upgrade. 
 
Additional Information:
Comment 1 Jeremy Katz 2002-08-21 01:13:48 EDT
Does rescue mode successfully mount the filesystems?
Comment 2 Douglas Kilpatrick 2002-08-21 10:01:56 EDT
I didn't try a flat "rescue mode".  I'll try that tonight.   Using the shell  
on console 2 did not work.  
  
mount /dev/Mirror/slash /mnt/sysimage  
  
produced an unexpected error message along the lines of "no such filename",  
even if /mny/sysimage already existed as a directory.
Comment 3 Douglas Kilpatrick 2002-08-22 13:10:24 EDT
Rescue mode also did not work (failed to mount anythin).  Doing a new install of
NULL, null did not see the "Stripe" LVM volume group at all, and that volume
group had to be recreated, but it did see the already existing Mirror
volume-group and Mirror's volumes.
Comment 4 Michael Fulbright 2002-09-27 16:03:18 EDT
This is a problem where we are not creating entries in /dev for raid devices
other than /dev/md0, so when we run vgscan it doesnt see LVM on raid devices
other than /dev/md0
Comment 5 Michael Fulbright 2002-09-27 16:56:57 EDT
*** Bug 74142 has been marked as a duplicate of this bug. ***
Comment 6 Jeremy Katz 2002-10-25 17:22:46 EDT
Fixed in CVS
Comment 7 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated
Comment 8 Jay Turner 2003-01-27 16:19:16 EST
Fix confirmed with re0127.nightly.

Note You need to log in before you can comment on or make changes to this bug.