Bug 719109 - user feedback was removed from subscription-manager identity --regenerate
Summary: user feedback was removed from subscription-manager identity --regenerate
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager   
(Show other bugs)
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: rc
: ---
Assignee: Bryan Kearney
QA Contact: John Sefler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: rhsm-rhel62
TreeView+ depends on / blocked
 
Reported: 2011-07-05 19:47 UTC by John Sefler
Modified: 2011-12-06 17:21 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 17:21:57 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2011:1695 normal SHIPPED_LIVE subscription-manager bug fix and enhancement update 2011-12-06 01:23:29 UTC

Description John Sefler 2011-07-05 19:47:39 UTC
Description of problem:
In prior versions of subscription-manager, stdout feedback was given after calling "subscription-manager identity --regenerate".  It seems to have been removed for rhel62.  Was this feedback removed on purpose?


Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.2-1.git.19.47243e5.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: 6eaebe7b-7b7e-4d84-9991-6c945f9b09f4 
[root@jsefler-onprem-62server ~]# subscription-manager identity --regenerate
[root@jsefler-onprem-62server ~]# 

  
Actual results:
No stdout feedback is given


Expected results:
In prior releases, the stdout feedback looked like this:
[root@jsefler-stage-5server product]# subscription-manager identity --regenerate
c56e9b0e-7e32-4a0a-87e1-5793961a61be jsefler-stage-5server.usersys.redhat.com


Additional info:

Comment 2 Bryan Kearney 2011-07-21 19:22:08 UTC
fixed in 3d861a15815402f6941713a87ce003c8bda18768 in master.

Comment 4 John Sefler 2011-07-26 17:43:39 UTC
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.63.7bb4765.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager register --username=testuser1 --password=password --org=admin
The system has been registered with id: bad99108-430f-4325-b506-14318b680db2 
[root@jsefler-onprem-62server ~]# subscription-manager identity --regenerate
Identity certificate has been regenerated.

Moving to VERIFIED

Comment 5 errata-xmlrpc 2011-12-06 17:21:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html


Note You need to log in before you can comment on or make changes to this bug.