Bug 71913 - man displays escape codes as ESC[xxx
man displays escape codes as ESC[xxx
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: man (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 01:55 EDT by Gordon Messmer
Modified: 2007-04-18 12:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-01-14 00:05:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gordon Messmer 2002-08-20 01:55:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Rather than interpreting the escape codes in man pages, the escape codes are shown.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. enter "man tempnam" in a gnome-terminal or xterm
	

Actual Results:  Escape codes are displayed, making the man page nearly unreadable.

Additional info:
Comment 1 Bill Nottingham 2002-08-20 22:50:38 EDT
Hm, this works for me ok in gnome-terminal. What locale are you running in? Is
this ssh'd into the beta box, or ssh from the beta box to a different system?
Comment 2 Gordon Messmer 2002-08-20 23:36:01 EDT
This is a clean install of (null), with a pre-existing user.  Before logging in
to X for the first time, I'd eliminated pretty much all config files except for
Galeon's, including .gnome* and .gconf/*
Comment 3 Need Real Name 2002-08-22 11:33:20 EDT
I've also noticed the same problem on my (null) install.  Just installed it this
morning and tried to do a 'man grep' in both a gnome-terminal and xterm.  Both
displayed the ESC codes.  This is my workstation that I'm physically sitting in
front of.
Comment 4 Michal Jaegermann 2002-08-25 18:04:28 EDT
This _may_ have something to do with broader problems described in #71913
and #72589.
Comment 5 cbagwell 2002-09-13 09:52:35 EDT
This is a "Me to".  I saw it after upgrading from 7.3.  I saw it in Limbo2 and
Null for sure... Don't think I looked at a man page in Limbo1.

I tried viewing man pages in gnome-terminal, xterm, uxterm, and konsole and they
all have the same problem that esc sequences are displayed as text instead of
changing to BOLD and other stuff.

Viewing man pages from the linux console works as expected.

I tried messing with the TERM variable with no success (linux, vt100, etc)... I
even tried using the LANG variable to see if that made a difference (it didn't).
 I upgraded to version 0.8.19-1 of vte since there was discussion of bugs in
that (but I don't think xterm uses that library) and the problem is still there.

My /etc/sysconfig/i18n is LANG="en_US".

I ran out of things to try.  Man is version 1.5j9.

Example first few lines of "man rpm".

RPM(8)                           Red Hat Linux                          RPM(8)  


ESC[1mNAMEESC[0m
       rpm - RPM Package Manager


Comment 6 Eido Inoue 2003-01-14 00:05:24 EST
this seems to work in 8.0

Note You need to log in before you can comment on or make changes to this bug.