Bug 71918 - No microcode found should NOT be an error
Summary: No microcode found should NOT be an error
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: kernel-utils   
(Show other bugs)
Version: null
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 06:49 UTC by Dax Kelson
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-20 06:49:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dax Kelson 2002-08-20 06:49:25 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3; Linux)

Description of problem:
I did an everything install of Null on my new Dell P4 laptop. On the first bootup, I get the nice message:

Applying Intel IA32 Microcode update:                      [FAILED]

I guess that is because my Mobile Pentium 4 doesn't have an update for it in /etc/firmware/microcode.dat.

If this the case (no update exists), it shouldn't result in a failure message. This is confusing/frightening for the newbie sys admin.



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Null on a new laptop with mobile Pentium 4.
2. Watch the pretty error message on boot.


Actual Results:  n/a

Expected Results:  n/a

Additional info:

tail /var/log/messages:
Aug 19 23:40:15 mentor microcode_ctl: microcode_ctl startup failed
Aug 19 23:40:15 mentor kernel: microcode: CPU0 no microcode found! (sig=f24, pflags=8)


# x86info
x86info v1.7.  Dave Jones 2001
Feedback to <davej@suse.de>.

Found 1 CPU
Family: 15 Model: 2 Stepping: 4 Type: 0 [Unknown CPU Original OEM]
Processor name string:        Intel(R) Pentium(R) 4 Mobile CPU 1.90GHz

Comment 1 Arjan van de Ven 2002-08-20 07:55:16 UTC
100% agreed. I yesterday fixed it so that the init script doesn't fail in the
"no newer firmware" case... that should do the trick.


Note You need to log in before you can comment on or make changes to this bug.