Bug 71921 - ignore locale cs_CZ
ignore locale cs_CZ
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: htdig (Show other bugs)
7.3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 04:28 EDT by Vaclav Dusek
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-13 08:32:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Vaclav Dusek 2002-08-20 04:28:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020607

Description of problem:
in htdig.conf is ignored tag
locale: cs_CZ
version htdig 1.x is OK

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.czech WWW site with Apache
2.in htdig.conf is direktive locale: cs_CZ
3.this directive is ignored with htsearch
	

Additional info:
Comment 1 Phil Knirsch 2002-08-20 07:41:12 EDT
Could you give a more specific and detailed description on how to reproduce this
problem?

With that little information i don't know how i should be able to reproduce it,
and reproduction of bugs locally is essential ;-).

So if you could give me step by step description of what i should try and what
the expected result and the actual results are i'd greatelly appreciate it.

Thanks,

Read ya, Phil
Comment 2 Vaclav Dusek 2002-08-20 14:19:41 EDT
htdig.conf

locale: cs_CZ
database_dir:           /var/lib/htdig/dusek
start_url:              http://dusek.upce.cz/

when i using search via WWW, i don't have czech characters in result - in result
is incorect special charcters &...; - not czech characters in ISO8859-2
Comment 3 Phil Knirsch 2003-09-02 08:51:49 EDT
Could you give the latest releases a try on a current Red Hat? Since 8.0 we have
utf-8 as default and this should be enough to have a consistent charset over all
apps.

Thanks,

Read ya, Phil
Comment 4 Gilles Detillieux 2003-10-30 10:53:22 EST
This bug should be fixed in snapshots of ht://Dig 3.2.0b4 on or after 20030615
(June 15, 2003), with the addition of the translate_latin1 attribute.  You'd
need to add

translate_latin1: false

to your htdig.conf file, to disable the translation of the ISO Latin 1 SGML
entities from your documents into upper end 8-bit characters in the database,
and then back to the Latin 1 SGML entities in htsearch results. Snapshots before
June 15 didn't have this attribute, and always did the translation. This might
require building your own RPM of htdig, as the most recent snapshot available as
a Red Hat update for 7.3 is the 011302 snapshot (Jan. 13, 2002).  Even rawhide
is still at 20030601.  Watch for ht://Dig 3.2.0rc1 coming hopefully in early
November.
Comment 5 Phil Knirsch 2004-01-13 08:32:59 EST
Thanks for the info, i've included the change in the latest Fedora
Core package for htdig now.

Read ya, Phil
Comment 6 Gilles Detillieux 2004-01-14 15:52:23 EST
Actually, what was released in November was 3.2.0b5.  Release Candidate 1 is still 
apparently a few months off.  However, 3.2.0b5 is far more solid than any of the 
3.2.0b4 development snapshots that have been RPM'ed.

Note You need to log in before you can comment on or make changes to this bug.