Bug 719260 - Secondary display does not work (multiseat radeon)
Secondary display does not work (multiseat radeon)
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
15
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dave Airlie
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-06 05:30 EDT by Jan "Yenya" Kasprzak
Modified: 2012-07-11 13:52 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-11 13:52:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan "Yenya" Kasprzak 2011-07-06 05:30:12 EDT
Description of problem:
I have a dual-seat workstation with two Radeon HD 3450 boards, two USB mice, one PS/2 and one USB keyboard. After upgrading to Fedora 15, the secondary head (the one which is not active during boot) stopped working: when the X server for it is started, the monitor comes out of sleep mode (the LED changes from amber to green), but nothing is displayed there. The X server for :1 is running, though.

I have tried to downgrade the X server and its dependencies to the F14 version, but it did not help. I have upgraded back to the F15 version and tried to use different kernels, which worked for some kernels:

F15 kernel-2.6.38.8-32.fc15.x86_64: does NOT work

F14 kernel (booted with init=/bin/bash, manually launching all necessary subsystems including xdm): works OK

vanila 2.6.38 compiled with the Fedora config (/boot/config-2.6.38.8-32.fc15.x86_64): works OK

vanila 2.6.39 kernel with the same config: does NOT work

vanilla 3.0-rc6 kernel with the same config: does NOT work

F15 kernel 2.6.38.8-32 with the following patches commented out:
drm-radeon-fix-regression-on-atom-cards-with-hardcoded-EDID-record.patch
drm-radeon-update.patch
drm-radeon-update2.patch
drm-radeon-pageflip-oops-fix.patch
does NOT work, so the problem is not in these patches.

I have tried to git-bisect the kernel source (from v2.6.38 to v2.6.39),
but there were too many unbootable intermediate versions which I had to "git bisect skip", so I did not get any useful information from it.

Version-Release number of selected component (if applicable):
kernel-2.6.38.8-32.fc15.x86_64

My VGA cards are the following, according to lspci:
01:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450]
05:00.0 VGA compatible controller: ATI Technologies Inc RV620 LE [Radeon HD 3450]

My X servers are started by xdm with the following configuration in the /etc/X11/xdm/Xservers file:

:0 local /usr/bin/X :0 -layout Primary -isolateDevice PCI:1:0:0 vt7
:1 local /usr/bin/X :1 -layout Secondary -isolateDevice PCI:5:0:0 -sharevts vt7

More information (log files, tests on different kernels, etc.) are available on request. Can I git-bisect the Fedora kernel somehow?
Comment 1 Alexei Podtelezhnikov 2011-07-28 14:14:27 EDT
Did you try to configure it manually using "xrandr" or Gnome settings? You should be able to activate your second monitor unless the driver is broken. Do you want to clone or extend the desktop? To the right or the the left? RTFM, in other words.
Comment 2 Jan "Yenya" Kasprzak 2011-08-04 10:40:33 EDT
Re: comment #1

Alexei, your comment does not make sense in the context of this bug. You are probably thinking dual-head setup (one X server process handling two screens, configured using xrandr from the inside of the GNOME or other desktop session of a single user), while this bug is about dual _seat_ setup (two independent X server processes, running two independent user sessions for two different users, each with his own keyboard, mouse, graphics card, and monitor).

In short, the problem occurs before users try to log in - the X server for the secondary head does not display any output (the XDM chooser is expected in this case). It is not a user configuration problem, but most probably a kernel one, as the problem appeared after upgrading to F15, and disappeared after downgrading the kernel and keeping the rest of F15 packages.
Comment 3 Josh Boyer 2012-06-06 11:52:48 EDT
There was a bit of multiseat work in F16 and F17.  If you haven't tried those already, you might give them a shot.
Comment 4 Josh Boyer 2012-07-11 13:52:12 EDT
Fedora 15 has reached it's end of life as of June 26, 2012.  As a result, we will not be fixing any remaining bugs found in Fedora 15.

In the event that you have upgraded to a newer release and the bug you reported is still present, please reopen the bug and set the version field to the newest release you have encountered the issue with.  Before doing so, please ensure you are testing the latest kernel update in that release and attach any new and relevant information you may have gathered.

Thank you for taking the time to file a report.  We hope newer versions of Fedora suit your needs.

Note You need to log in before you can comment on or make changes to this bug.