Bug 719272 - df: `/root/.gvfs': Permission denied
Summary: df: `/root/.gvfs': Permission denied
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: gvfs
Version: 14
Hardware: Unspecified
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Tomáš Bžatek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-06 10:14 UTC by Berthault
Modified: 2015-03-03 23:01 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-20 13:02:26 UTC


Attachments (Terms of Use)

Description Berthault 2011-07-06 10:14:23 UTC
Description of problem:
On Fedora-14 (with all updates applied), when I execute the "df" command, I have the following message at the end of the report:
df: `/root/.gvfs': Permission denied

I don't understand why Fedora want to access the .gvfs directory of root because I am not logged as root.

Version-Release number of selected component (if applicable):
rpm -qa | grep gvfs
gvfs-archive-1.6.6-1.fc14.i686
gvfs-fuse-1.6.6-1.fc14.i686
gvfs-obexftp-1.6.6-1.fc14.i686
gvfs-1.6.6-1.fc14.i686
gvfs-smb-1.6.6-1.fc14.i686
gvfs-gphoto2-1.6.6-1.fc14.i686
gvfs-afc-1.6.6-1.fc14.i686

How reproducible:

Steps to Reproduce:
1.
2.
3.
  
Actual results:

Expected results:

Additional info:

Comment 1 Berthault 2011-07-06 10:44:55 UTC
This problem has disappeared after a reboot of the system.

Comment 2 Tomáš Bžatek 2011-07-20 13:02:26 UTC
This typically happens when you run gnome-session or any other gnome app under root, autospawning gvfs-fuse-daemon. At first, Gnome apps should not be run under root nor su/sudo. As a second note, this is a design issue of FUSE mounts, denying access to other users - system tools should be aware of it and ignore.


Note You need to log in before you can comment on or make changes to this bug.