Bug 719309 - build failure in rawhide, error: expected identifier or '(' before 'long'
build failure in rawhide, error: expected identifier or '(' before 'long'
Status: CLOSED DUPLICATE of bug 716021
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
powerpc Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeroen van Meeuwen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F16Alphappc
  Show dependency treegraph
 
Reported: 2011-07-06 09:01 EDT by Karsten Hopp
Modified: 2012-03-14 09:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-06 11:12:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2011-07-06 09:01:09 EDT
Description of problem:
gcc -I. -I../.. -I../../. -I../.././ext/dl -DHAVE_DLFCN_H -DHAVE_DLOPEN -DHAVE_DLCLOSE -DHAVE_DLSYM -DHAVE_DLERROR  -D_FILE_OFFSET_BITS=64  -I. -fPIC -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -Wl,-z,relro -m32 -fno-strict-aliasing  -fPIC  -fno-defer-pop -fno-omit-frame-pointer  -c dl.c
In file included from dl.c:104:0:
callback.func:1:1: warning: data definition has no type or storage class [enabled by default]
callback.func:1:1: warning: type defaults to 'int' in declaration of 'rg11' [-Wimplicit-int]
callback.func:1:7: error: expected identifier or '(' before 'long'
In file included from dl.c:104:0:
callback.func:78:33: error: expected ')' before '(' token
callback.func:79:3: warning: data definition has no type or storage class [enabled by default]
callback.func:79:3: warning: type defaults to 'int' in declaration of 'retval' [-Wimplicit-int]
callback.func:79:24: error: 'proc' undeclared here (not in a function)
callback.func:79:39: error: 'argc' undeclared here (not in a function)
callback.func:79:45: error: 'argv' undeclared here (not in a function)
callback.func:82:1: error: expected identifier or '(' before '}' token

Version-Release number of selected component (if applicable):
ruby-1.8.7.334-2.fc16

How reproducible:
always

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=247499
Comment 1 Mamoru TASAKA 2011-07-06 11:12:05 EDT

*** This bug has been marked as a duplicate of bug 716021 ***

Note You need to log in before you can comment on or make changes to this bug.