Bug 719323 (libkipi) - Review Request: libkipi - Common plugin infrastructure for KDE image applications
Summary: Review Request: libkipi - Common plugin infrastructure for KDE image applicat...
Keywords:
Status: CLOSED RAWHIDE
Alias: libkipi
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: nucleo
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: gwenview okular
TreeView+ depends on / blocked
 
Reported: 2011-07-06 13:49 UTC by Rex Dieter
Modified: 2016-09-19 04:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-11 17:43:24 UTC
alekcejk: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Rex Dieter 2011-07-06 13:49:13 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/kdegraphics/libkipi.spec
SRPM URL: http://rdieter.fedorapeople.org/rpms/kdegraphics/libkipi-4.6.90-1.fc16.src.rpm
Description: Common plugin infrastructure for KDE image applications

Comment 1 nucleo 2011-07-06 16:53:03 UTC
Almost all sources in libkipi GPLv2+ and only libkipi_export.h have LGPLv2+ license so resulting license maybe is GPLv2+?

scratch build: http://koji.fedoraproject.org/koji/taskinfo?taskID=3182848

rpmlint output:

libkipi.i686: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi.i686: E: zero-length /usr/share/doc/libkipi-4.6.90/TODO
libkipi.src: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi.src: W: invalid-url Source0: ftp://ftp.kde.org/pub/kde/stable/4.6.90/src/libkipi-4.6.90.tar.bz2 <urlopen error ftp error: 550 Failed to change directory.>
libkipi.x86_64: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi.x86_64: E: zero-length /usr/share/doc/libkipi-4.6.90/TODO
libkipi-devel.i686: W: no-documentation
libkipi-devel.x86_64: W: no-documentation
7 packages and 0 specfiles checked; 2 errors, 6 warnings.

TODO file is empty (NEWS can be added instead it).

invalid-url error because 4.6.90 is in unstable dir.

Comment 2 nucleo 2011-07-06 17:39:34 UTC
Is update-desktop-database really needed?
kipiplugin.desktop installed in /usr/share/kde4/servicetypes but update-desktop-database searches files in /usr/share/applications.

Comment 3 Rex Dieter 2011-07-06 17:45:01 UTC
nope, it's not needed, thanks.  I'll fix up those issues, and upload a new one here shortly.

Comment 4 Rex Dieter 2011-07-06 17:48:12 UTC
Spec URL: http://rdieter.fedorapeople.org/rpms/kdegraphics/libkipi.spec
SRPM URL:
http://rdieter.fedorapeople.org/rpms/kdegraphics/libkipi-4.6.90-2.fc15.src.rpm

%changelog
* Wed Jul 06 2011 Rex Dieter <rdieter@fedoraproject.org> 4.6.90-2
- License: GPLv2+
- fix scriptlets
- %%doc: +NEWS, -TODO

Comment 5 Rex Dieter 2011-07-06 17:48:43 UTC
and
%changelog
- fix URL

Comment 6 nucleo 2011-07-09 14:11:59 UTC
rpmlint output for libkipi-4.6.90-3* rpms and -debuginfo:
libkipi.i686: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi.src: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi.x86_64: W: spelling-error %description -l en_US Kipi -> Kip, Ki pi, Ki-pi
libkipi-devel.i686: W: no-documentation
libkipi-devel.x86_64: W: no-documentation

Comment 7 nucleo 2011-07-09 14:26:23 UTC
So all issues fixed now.
Package and spec names are fine, 
license GPLv2+ is actual license used in libkipi sources, 
Requires in devel packages is %{name}%{?_isa} = %{version}-%{release},
scriptlets are fine.

Package APPROVED

Comment 8 nucleo 2011-07-09 14:38:21 UTC
Is this package will be built after all other packages from kdegraphics will be ready?

Comment 9 Rex Dieter 2011-07-10 14:58:03 UTC
Wrt when to build this, we'll probably wait until the stack up through okular is reviewed first.

Imported (using prior/old libkipi module from kde3 era...)

Comment 10 Rex Dieter 2011-07-10 15:04:42 UTC
Looks like this is deprecated in pkgdb, we'll need intervention.


Package Change Request
======================
Package Name: libkipi
Owners: than rdieter jreznik kkofler ltinkl rnovacek rrix

Comment 11 nucleo 2011-07-11 01:22:20 UTC
It is will be better to change URL to
https://projects.kde.org/projects/kde/kdegraphics/libs/libkipi
Sorry that I not noticed this before.

Comment 12 Gwyn Ciesla 2011-07-11 15:10:33 UTC
Misformed request, what sort of intervention are you referring to?

Comment 13 Rex Dieter 2011-07-11 16:54:29 UTC
Package Change Request
======================
Package Name: libkipi
Short Description: Common plugin infrastructure for KDE image applications
Owners: than rdieter jreznik kkofler ltinkl rnovacek rrix
Branches: f15


3 things needed: 
1. updated owners
2. f15 branch
3. mark package not deprecated in pkgdb

Comment 14 Gwyn Ciesla 2011-07-11 17:12:34 UTC
Git done (by process-git-requests).

Comment 15 Gwyn Ciesla 2011-07-11 17:13:57 UTC
Created f15 branch, I can't do 1 or 3, you'll need to file a rel-eng trac.

Comment 16 Rex Dieter 2011-07-11 17:43:24 UTC
Ok, thanks!

Comment 17 Marcus Harrison 2016-09-19 04:34:00 UTC
Not sure if this is where I should report this, but on my Fedora 22 system, running "dnf remove libkipi" results in the error, "The operation would result in removing the following protected packages: systemd."


Note You need to log in before you can comment on or make changes to this bug.