Bug 719437 - Provide native systemd unit file for proftpd
Provide native systemd unit file for proftpd
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: proftpd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-06 16:20 EDT by Jóhann B. Guðmundsson
Modified: 2011-10-15 21:00 EDT (History)
3 users (show)

See Also:
Fixed In Version: proftpd-1.3.4-0.11.rc2.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:08:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file proftpd (254 bytes, text/plain)
2011-07-06 16:21 EDT, Jóhann B. Guðmundsson
no flags Details
with -n (209 bytes, text/plain)
2011-07-06 17:08 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-06 16:20:12 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Paul Howarth 2011-07-06 16:29:54 EDT
Would it not be better to run proftpd in the foreground (--nodaemon) with systemd rather than in forking mode?

http://linux.die.net/man/8/proftpd
Comment 3 Jóhann B. Guðmundsson 2011-07-06 17:08:52 EDT
Created attachment 511583 [details]
with -n
Comment 4 Jóhann B. Guðmundsson 2011-07-06 17:09:16 EDT
(In reply to comment #2)
> Would it not be better to run proftpd in the foreground (--nodaemon) with
> systemd rather than in forking mode?
> 
> http://linux.die.net/man/8/proftpd

Take your pick...
Comment 5 Tom "spot" Callaway 2011-09-12 13:54:56 EDT
--nodaemon doesn't seem right to me, because it says that this requires special configuration and does not output logging to syslog. I matched it up to the behavior of the initscript, which was to allow /etc/sysconfig/proftpd options as an override and not use -n/--nodaemon by default.
Comment 6 Fedora Update System 2011-09-12 14:16:41 EDT
proftpd-1.3.4-0.11.rc2.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/proftpd-1.3.4-0.11.rc2.fc16
Comment 7 Fedora Update System 2011-09-12 20:10:03 EDT
Package proftpd-1.3.4-0.11.rc2.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing proftpd-1.3.4-0.11.rc2.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/proftpd-1.3.4-0.11.rc2.fc16
then log in and leave karma (feedback).
Comment 8 Paul Howarth 2011-09-13 02:47:55 EDT
*** Bug 737707 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2011-09-30 04:33:52 EDT
proftpd-1.3.4-0.14.rc3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-13525
Comment 10 Fedora Update System 2011-09-30 15:08:23 EDT
proftpd-1.3.4-0.11.rc2.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-10-15 21:00:05 EDT
proftpd-1.3.4-0.15.rc3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.