Bug 71945 - RFE: The initial run of updatedb should not be right after installation
RFE: The initial run of updatedb should not be right after installation
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Jay Turner
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 08:56 EDT by Bernd Bartmann
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 11:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-08-20 08:56:03 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
I propose to delay the initial run of updatedb after installation to a later 
time. A first time user gets the impression of a very slow system when 
updatedb is running. Even the startup of firstboot takes ages cause updatedb 
is running in the background.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install (Null)
2. Watch "top" some minutes after the initial install 
3.
	

Additional info:
Comment 1 Barry K. Nathan 2002-08-27 05:26:35 EDT
More generically, it often seems to run shortly after boot, and that can be
annoying sometimes.

It would be neat if updatedb could somehow limit the amount of disk access it
does when it runs soon after boot (or maybe even when it runs from the daily
cronjob, although that I'm not so sure about). I guess it's too late to do it
for this release. (It might be even better to add some kind of "disk-nice"
feature to the kernel, but I'm virtually certain it's too late to do it for this
release.)
Comment 2 Bernd Bartmann 2003-07-30 11:56:32 EDT
Seems to be fixed since Red Hat 9, so I'm closing this bug now.

Note You need to log in before you can comment on or make changes to this bug.