Bug 719462 - Provide native systemd unit file
Provide native systemd unit file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: nsd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Paul Wouters
Fedora Extras Quality Assurance
:
Depends On:
Blocks: SysVtoSystemd
  Show dependency treegraph
 
Reported: 2011-07-06 19:52 EDT by Jóhann B. Guðmundsson
Modified: 2011-09-30 15:52 EDT (History)
3 users (show)

See Also:
Fixed In Version: nsd-3.2.8-7.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-09-30 15:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file for nsd (463 bytes, text/plain)
2011-07-06 19:55 EDT, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for nsd with reload (572 bytes, text/plain)
2011-07-06 20:30 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-07-06 19:52:55 EDT
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 2 Jóhann B. Guðmundsson 2011-07-06 20:30:46 EDT
Created attachment 511603 [details]
Native systemd service file for nsd with reload

I attached the wrong file in first round here is the "the real one" 

Note that there seems to be something a miss with the reload process of the nscd 
( ExecReload=/usr/sbin/nsdc -c /etc/nsd/nsd.conf reload ) 

Jul  7 00:22:48 valhalla nsd[15434]: signal received, reloading...
Jul  7 00:22:48 valhalla nsd[15486]: memory recyclebin holds 0 bytes
Jul  7 00:22:48 valhalla nsd[15486]: signal received, shutting down...
Jul  7 00:22:48 valhalla nsd[15486]: failed to unlink pidfile /var/run/nsd/nsd.pid: Permission denied <--
Jul  7 00:22:48 valhalla nsd[15486]: server_main: could not send quit to xfrd:  Broken pipe <--

You probably need to create a bug upstream and have them take look at it
Comment 3 Greg 2011-08-22 08:11:56 EDT
I also created a configuration file to create a '/var/run/nsd' directory.
The file is '/etc/tmpfiles.d/nsd.conf' with the one line of content:

d /run/nsd 0755 nsd nsd -
Comment 4 Fedora Update System 2011-09-12 14:34:07 EDT
nsd-3.2.8-7.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nsd-3.2.8-7.fc16
Comment 5 Fedora Update System 2011-09-12 20:11:03 EDT
Package nsd-3.2.8-7.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nsd-3.2.8-7.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/nsd-3.2.8-7.fc16
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2011-09-30 15:51:52 EDT
nsd-3.2.8-7.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.