Bug 71948 - gnome-sound-recorder doesn't record or play sounds
gnome-sound-recorder doesn't record or play sounds
Status: CLOSED CURRENTRELEASE
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-media (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks: 67218
  Show dependency treegraph
 
Reported: 2002-08-20 09:03 EDT by Need Real Name
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-09-02 00:34:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-20 09:03:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.5 (X11; Linux i686; U;) Gecko/20020809

Description of problem:
Problem 1: recording doesn't work

Gnome-sound-recorder stops recording about 1 second after I hit the "Record"
button.  If I then hit the "Play" button, it stops after about 1 second.  If try
to save a file I have "recorded", nothing gets written to the disk.  There are
no error/warning dialogs/pop-ups.

If I start gnome-sound-recorder from an xterm, instead of the menu, then I see
this message:
"Audio File Library: could not open file '/tmp/untitled.wav' [error 3]"

Problem 2: playing doesn't work

Gnome-sound-recorder doesn't play sound files I record with another program.  If
I open a pre-recorded file in gnome-sound-recorder  and hit the "Play" button, I
get no sound.  I get these error messages if I run gnome-sound-recorder from an
xterm (no error/warning dialogs/popups if I start from the menu) and try playing
sounds (first message when I open the file, second message when I hit "Play"):
"Audio File Library: warning: opening file for read access: ignoring file setup
with non-raw file format [error 23]"
"Audio File Library: warning: opening file for read access: ignoring file setup
with non-raw file format [error 23]"

This is what "file" says about the file I tried to open and play in
gnome-sound-recorder:
[grover@slick grover]$ file record000.wav
"record000.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit,
stereo 44100 Hz"


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. start gnome-sound-recorder
2. press the "Record" button
3. press the "Play" button, try to save, or do anything useful
	

Actual Results:  nada

Expected Results:  Some sounds should get recorded; I should be able to save
those sounds in a file; I should be able to play sounds from a file.

Additional info:

This is not a general sound configuration error or a hardware problem.  I can
record sounds using the kde sound-recording utility and also using "record" from
the command line.

I first noticed this bug under the limbo-2 beta (not sure if it was present in
limbo-1).  It persists under the null (7.3.94) beta.
Comment 1 Havoc Pennington 2002-08-21 19:44:12 EDT
should probably at least remove it from menus, if it can't be convinced to work.
Comment 2 Need Real Name 2002-09-02 00:34:14 EDT
Installing gnome-media-2.0.0-8.i386.rpm fixed this problem.
Comment 3 Brent Fox 2002-10-18 21:25:50 EDT
Ok, resolving as 'currentrelease' since we shipped gnome-media-2.0.0-9.

Note You need to log in before you can comment on or make changes to this bug.