Bug 719519 - [abrt] gwibber-3.1.0-1.fc15: connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1
Summary: [abrt] gwibber-3.1.0-1.fc15: connection.py:630:call_blocking:DBusException: o...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gwibber
Version: 15
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tom "spot" Callaway
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:e8d3255b3e3db5391e46fcb67eb...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-07 06:29 UTC by Matthias Runge
Modified: 2012-03-17 23:56 UTC (History)
6 users (show)

Fixed In Version: gwibber-3.1.0-4.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-17 23:47:54 UTC
Type: ---


Attachments (Terms of Use)

Description Matthias Runge 2011-07-07 06:29:02 UTC
abrt version: 2.0.3
architecture:   x86_64
cmdline:        /usr/bin/python /usr/bin/gwibber
component:      gwibber
executable:     /usr/bin/gwibber
kernel:         2.6.38.8-32.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        gwibber-3.1.0-1.fc15
reason:         connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1
time:           Thu Jul  7 08:20:12 2011
uid:            500
username:       mrunge

backtrace:
:connection.py:630:call_blocking:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1
:
:Traceback (most recent call last):
:  File "/usr/bin/gwibber", line 98, in <module>
:    client.Client()
:  File "/usr/lib/python2.7/site-packages/gwibber/client.py", line 699, in __init__
:    self.w = GwibberClient()
:  File "/usr/lib/python2.7/site-packages/gwibber/client.py", line 40, in __init__
:    self.model = gwui.Model()
:  File "/usr/lib/python2.7/site-packages/gwibber/gwui.py", line 51, in __init__
:    self.services = json.loads(self.daemon.GetServices())
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 68, in __call__
:    return self._proxy_method(*args, **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1
:
:Local variables in innermost frame:
:byte_arrays: False
:self: <dbus._dbus.SessionBus (session) at 0x1c8db30>
:args: ()
:utf8_strings: False
:bus_name: 'com.Gwibber.Service'
:get_args_opts: {'byte_arrays': False, 'utf8_strings': False}
:object_path: '/com/gwibber/Service'
:timeout: -1.0
:signature: None
:dbus_interface: 'com.Gwibber.Service'
:message: <dbus.lowlevel.MethodCallMessage object at 0x1d9e1c8>
:method: 'GetServices'

comment:
:Start up gwibber, this is repeatable,  selinux disabled
:
:this is a regression against gwibber-3.0.0.1-2.fc15.
:
:[mrunge@mrungexp ~]$ gwibber -d
:ERROR:dbus.proxies:Introspect error on com.Gwibber.Service:/com/gwibber/Service: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1
:Traceback (most recent call last):
:  File "/usr/bin/gwibber", line 98, in <module>
:    client.Client()
:  File "/usr/lib/python2.7/site-packages/gwibber/client.py", line 699, in __init__
:    self.w = GwibberClient()
:  File "/usr/lib/python2.7/site-packages/gwibber/client.py", line 40, in __init__
:    self.model = gwui.Model()
:  File "/usr/lib/python2.7/site-packages/gwibber/gwui.py", line 51, in __init__
:    self.services = json.loads(self.daemon.GetServices())
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 68, in __call__
:    return self._proxy_method(*args, **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/proxies.py", line 140, in __call__
:    **keywords)
:  File "/usr/lib/python2.7/site-packages/dbus/connection.py", line 630, in call_blocking
:    message, timeout)
:dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Process /usr/bin/gwibber-service exited with status 1

Comment 1 Ralf Oltmanns 2011-07-08 14:36:53 UTC
Package: gwibber-3.1.0-1.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Gwibber crashes immediately when started. Please see also Bug #719963 which resulted from the the same crash but created its own ABRT report.

Be advised that NetworkManager is not active on this host and cannot be activated as it is incompatible with our network setup

Comment 2 Rik van Riel 2011-08-04 18:03:29 UTC
Package: gwibber-3.1.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
X was hanging due to some Radeon problem, so I logged in over ssh and killed it.

After logging back in, I am unable to start gwibber.

Comment 3 Owen Carter 2011-08-26 13:06:21 UTC
Package: gwibber-3.1.0-2.fc15
Architecture: x86_64
OS Release: Fedora release 15 (Lovelock)

Comment
-----
Any attempt to run GWibber causes this.
Note; I see another crash (to be reported after this) where NetworkManager is referenced. I have NM installed but not started since it interferes with the bridge network setup I need to use on this machine.

Comment 4 Matthias Runge 2011-09-07 15:07:39 UTC
I can confirm, if networkManager started, gwibber runs; NetworkManager stopped, network via ifconfig/ifup dhclient enabled, gwibber crashes.

Comment 5 Andrea Dell'Amico 2012-02-06 13:46:21 UTC
gwibber crashed while starting.

Package: gwibber-3.1.0-2.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment 6 Andrea Dell'Amico 2012-03-02 10:39:19 UTC
The package was updated, but the error remains.


Package: gwibber-3.1.0-3.fc16
Architecture: i686
OS Release: Fedora release 16 (Verne)

Comment 7 Tom "spot" Callaway 2012-03-02 17:10:17 UTC
Okay. Fixing this 3.1.* code is a bit tricky, especially since upstream doesn't look at all like this anymore (but the 3.3 code which is current will only work on Fedora 17+ due to dependencies), but I think at least this bug is addressable. Please test the 3.1.0-4 build (coming real soon).

Comment 8 Fedora Update System 2012-03-02 17:30:01 UTC
gwibber-3.1.0-4.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-4.fc15

Comment 9 Fedora Update System 2012-03-02 17:30:11 UTC
gwibber-3.1.0-4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/gwibber-3.1.0-4.fc16

Comment 10 Andrea Dell'Amico 2012-03-02 17:48:10 UTC
Manually downloaded and installed the package. Now it works.
Thanks!

Comment 11 Fedora Update System 2012-03-06 19:23:18 UTC
Package gwibber-3.1.0-4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gwibber-3.1.0-4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2990/gwibber-3.1.0-4.fc16
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-03-17 23:47:54 UTC
gwibber-3.1.0-4.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Fedora Update System 2012-03-17 23:56:54 UTC
gwibber-3.1.0-4.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.