Bug 719572 - gnome-control-center keeps crashing in libcolor.so when plugging in Datacolor Spyder 3 elite device
Summary: gnome-control-center keeps crashing in libcolor.so when plugging in Datacolor...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: control-center
Version: 15
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Control Center Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-07 11:16 UTC by Mark Moses
Modified: 2011-11-14 12:56 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-11-14 12:56:37 UTC
Type: ---


Attachments (Terms of Use)
/var/spool/abrt/ccpp-2011-07-06-20:20:58-5605 (2.28 MB, application/x-gzip)
2011-07-07 11:16 UTC, Mark Moses
no flags Details
/var/log/messages ( relevant parts) (34.06 KB, application/octet-stream)
2011-07-07 11:17 UTC, Mark Moses
no flags Details
rpm -qa output (41.77 KB, text/plain)
2011-07-07 11:18 UTC, Mark Moses
no flags Details

Description Mark Moses 2011-07-07 11:16:01 UTC
Created attachment 511673 [details]
/var/spool/abrt/ccpp-2011-07-06-20:20:58-5605

Description of problem:
gnome-control-center keeps crashing in libcolor.so when plugging in Datacolor Spyder 3 elite device. This behaviour continues till I unplug the device.

Version-Release number of selected component (if applicable):
3.0.1.1-5.fc15


How reproducible:
Log into X session and plug in the device. Happens every time.


Steps to Reproduce:
1. Install Fedora 15 as desktop and "yum update"
2. Plug in a datacolor spyder 3 elite usb device
3. Watch gnome-control-center crash continuously
  
Actual results:
gnome-control-center segfaults, is restarted and segfaults again till the spyder is removed:
Jul  6 20:21:11 kvm kernel: [ 2497.782933] gnome-control-c[6259]: segfault at 50 ip 00007fafaf745ba5 sp 00007fff563482e0 error 4 in 

libcolor.so[7fafaf735000+3e000]


Expected results:
gnome-control-center is started with possibilities to create an icc profile using the spyder3 usb device.

Additional info:
I will attach relevant parts of /var/log/messages and /var/spool/abrt

Comment 1 Mark Moses 2011-07-07 11:17:21 UTC
Created attachment 511674 [details]
/var/log/messages ( relevant parts)

Here are the relevant parts of /var/log/messages

Comment 2 Mark Moses 2011-07-07 11:18:22 UTC
Created attachment 511675 [details]
rpm -qa output

Here is the complete list of rpm's installed on my box

Comment 3 Mark Moses 2011-08-18 07:35:08 UTC
I'm not a c programmer but I'm going to try and put some more information on what might have caused this by using gdb:


[root@kvm rpmbuild]# gdb '/usr/bin/gnome-control-center color' /var/spool/abrt/ccpp-2011-07-06-18:10:42-2537/coredump

<lines removed>

Core was generated by `/usr/bin/gnome-control-center color'.
Program terminated with signal 11, Segmentation fault.
#0  cc_color_panel_startup_idle_cb (panel=0x243b430) at cc-color-panel.c:2205
2205            ret = g_settings_get_boolean (panel->priv->settings, GCM_SETTINGS_USE_PROFILES_FROM_VOLUMES);
Missing separate debuginfos, use: debuginfo-install ibus-gtk3-1.3.99.20110419-12.fc15.x86_64 ibus-libs-1.3.99.20110419-12.fc15.x86_64
(gdb) print panel->priv->settings
Cannot access memory at address 0x50
(gdb) print panel
$1 = 0x243b430
(gdb) print panel->priv
$2 = (CcColorPanelPrivate *) 0x0
(gdb)

If I get this right panel->priv is a NULL reference and that is causing the segmentation fault... Can anyone comment on this?

Comment 4 Richard Hughes 2011-08-19 08:33:44 UTC
(In reply to comment #3)
> (gdb) print panel->priv
> $2 = (CcColorPanelPrivate *) 0x0

So, this looks like either this code is being hit before the panel is instantiated (unlikely, as cc_color_panel_startup_idle_cb is setup as an idle action in the cc_color_panel_init() function, of that it's run after the panel is destroyed.

Did you have the control center open when you plugged in your device? Thanks.

Comment 5 Mark Moses 2011-08-19 10:17:03 UTC
Thanks for having a look!

I had it closed, but I also tried with control-center open. Both result in a continuous crashing.

Comment 6 Dennis Appelon Nielsen 2011-10-03 14:24:27 UTC
I can confirm this, exactly as described above.

What is happing on this bug, are there being corrected some code,there are waiting to go to Fedora repo's soon

Comment 7 Dennis Appelon Nielsen 2011-11-14 12:56:37 UTC
It is fixed with the Release for Fedora 16

Still not working with rpmfusions.net's kmod-nvidia and akmod-nvidia, but I guess that is a rpmfusion nvidia driver problem.....


Note You need to log in before you can comment on or make changes to this bug.