Bug 71958 - mc color scheme on the console looks terrible
mc color scheme on the console looks terrible
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: mc (Show other bugs)
8.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 09:46 EDT by Bernd Bartmann
Modified: 2015-01-07 18:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-03 17:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernd Bartmann 2002-08-20 09:46:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1)

Description of problem:
The new color scheme for mc on the console looks terrible. The texts in the 
menus are nearly unreadable (grey? on green?). Please revert to the old color 
scheme from Red Hat 7.3

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start mc from the console
2. Look at the unreadable texts in the menus
3.
	

Additional info:
Comment 1 Bill Nottingham 2002-08-20 23:07:42 EDT
The color scheme didn't change, the capabilities of the console did.

From the release notes:

Distribution General Notes

     * Red Hat Linux now installs using UTF-8 (Unicode) locales by default.
       This has been known to cause various issues:
       7 Line drawing characters in applications such as make menuconfig do not
appear correctly in certain locales.
       7 On the console, the LatArCyrHeb-16 font is used for best Unicode
coverage. Due to the use of this font, bold colors are not available.


This is probably due to the latter point.
Comment 2 Bernd Bartmann 2002-08-21 06:00:33 EDT
What do you mean by "bold colors"? I still don't understand how to change of the
locale and font is related to the color.
Comment 3 Andrea Diodato 2002-12-17 12:32:55 EST
At boot you can see [ OK ] dark geen.
Changing the font don't work!
All programs that use the console don't work so!!
setpalette (SVGATextMode) don't work also!!
I can't utilize RH8.0!!
I have 1600 people that use a text mode program with colors!!
Comment 4 Havoc Pennington 2003-02-03 17:59:16 EST
If I understand notting's point there's no way to fix this in mc.
Comment 5 Matt Wilson 2003-02-03 19:26:39 EST
run 'modprobe vga16fb' in the next version, and you will have bright colors.
Comment 6 Matt Wilson 2003-02-03 19:27:28 EST
another option in 8.0 is to boot with "linux vga=792" or other vesafb mode. 
This will also give you bright colors on the console.

Note You need to log in before you can comment on or make changes to this bug.