Bug 7196 - Updated bootnet image doesn't boot.
Updated bootnet image doesn't boot.
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-11-21 04:59 EST by osman
Modified: 2015-01-07 18:39 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 08:39:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description osman 1999-11-21 04:59:22 EST
I have used the updated bootnet.img the one in the updates tree...
It works great until I reboot the machine to bootup on its own.
It stops at the LILO promt at "LI"
I use only SCSI with a 3C900(PCI-Vortex) card.
I think the process doesn't run LILO properly...
Comment 1 Jay Turner 1999-11-22 13:18:59 EST
Where did you install lilo (mbr or first sector of the boot partition?)  Also,
if there was once a mbr lilo installed, but you are now running lilo from the
first sector of the boot partition, then the system might be seeing the
installation in mbr and failing from this.  If you believe this to be the case,
then you might want to do one of two things.  1) install lilo back into the mbr
or 2) remove lilo from the mbr, leaving it on the first sector of the boot
partition (using the lilo -u parameter)
Comment 2 osman 1999-11-22 15:16:59 EST
I didn't get any option where to install the lilo...
I used the option to install the GNOME veraion from the menu.
As I used DHCP+NFS to install and can't boot that linux machine, I can't solve
this lilo problem.
A new install should work without corrections of this type anyway...
Comment 3 Jay Turner 1999-11-29 12:10:59 EST
Boot the machine into rescue mode and send me a copy of your /etc/lilo.conf file
as well as your /etc/fstab

To boot into rescue mode, you are going to need to boot from the diskette with
"linux rescue" at the boot prompt.  You will proceed just as you did with the
installation, telling the installer where the source files are, and then you
will get dumped at a shell prompt.

Make a directory somewhere so that you can use it as a mount point (so "mkdir
/mnt/tmp" will do) and then mount your root partition on it (so "mount
/dev/<root partition> /mnt/tmp")

You will then be able to cd to /mnt/tmp and get access to your root partition.
I am thinking that for some reason, the GNOME Workstation installation is not
acting as it should with respect to your SCSI drive system.

Another option is that you can just perform a custom installation, selecting to
install GNOME and then you will be able to specify the location at which lilo
get installed.  This should help out alot, as I am thinking that for some
reason, lilo is getting written to the first sector of the root partition as
opposed to the MBR of the drive and this is causing the problem you are seeing.
Comment 4 Jay Turner 2000-02-09 08:39:59 EST
Closing out bug due to lack of activity.

Note You need to log in before you can comment on or make changes to this bug.