Bug 719654 - yumdownloader does not download SRPM when '--source' flag is provided
Summary: yumdownloader does not download SRPM when '--source' flag is provided
Keywords:
Status: CLOSED DUPLICATE of bug 710469
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: yum-utils
Version: 6.1
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: James Antill
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-07 15:22 UTC by josh.yggdrasil
Modified: 2014-01-21 06:23 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2011-07-07 16:16:38 UTC


Attachments (Terms of Use)

Description josh.yggdrasil 2011-07-07 15:22:30 UTC
Description of problem:
yumdownloader does not download Source RPMs when (SRPM) provided '--source' flag

Version-Release number of selected component (if applicable):
# yumdownloader --version
yumdownloader - 1.0 (yum - 3.2.29)

How reproducible:
Reproduced on one system, confirmed by at least one other person.

Steps to Reproduce:
(Using GCC as an example)
1.  install yumdownloader, if not already installed
2.  type 'yumdownloader --source gcc'
  
Actual results: It says there is no Source RPM, and nothing to download
# yumdownloader --source gcc (Example From RedHat '6Server')
Loaded plugins: product-id, refresh-packagekit, rhnplugin
No source RPM found for gcc-4.4.4-13.el6.x86_64
No source RPM found for gcc-4.4.5-6.el6.x86_64
Nothing to download
# 

Expected results: This it downloads a Source RPM (example from working CentOS5
# yumdownloader --source gcc
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.5ninesolutions.com
 * extras: mirrors.usc.edu
 * updates: mirror.5ninesolutions.com
gcc-4.1.2-50.el5.src.rpm                                 |  37 MB     00:03
#

Additional info:
*Also tried with enabled/disabled repositories; example: (though I've been told this shouldn't make a difference)

[rhel-source]
name=Red Hat Enterprise Linux $releasever - $basearch - Source
baseurl=ftp://ftp.redhat.com/pub/redhat/linux/enterprise/$releasever/en/os/SRPMS/
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-release

*Works without --source flag
# yumdownloader gcc
Loaded plugins: product-id, refresh-packagekit, rhnplugin
gcc-4.4.5-6.el6.x86_64.rpm  

*Fails with packages aside from GCC
# yumdownloader --source gedit
Loaded plugins: product-id, refresh-packagekit, rhnplugin
No source RPM found for 1:gedit-2.28.4-3.el6.x86_64
Nothing to download

*Confirmed existance of src.rpm files via ftp to ftp.redhat.com
# ftp ftp.redhat.com
Connected to ftp.redhat.com.
220 Red Hat FTP server ready. All transfers are logged. (FTP) [no EPSV]
530 Please login with USER and PASS.
530 Please login with USER and PASS.
KERBEROS_V4 rejected as an authentication type
Name (ftp.redhat.com:root): anonymous
331 Please specify the password.
Password:
230 Login successful.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> cd /pub/redhat/linux/enterprise/6Server/en/os/SRPMS
250 Directory successfully changed.
ftp> ls gcc*
227 Entering Passive Mode (209,132,183,61,163,217).
150 Here comes the directory listing.
-rw-r--r--    4 ftp      ftp      52214716 Aug 17  2010 gcc-4.4.4-13.el6.src.rpm
-rw-r--r--    5 ftp      ftp      52113813 Apr 21 20:28 gcc-4.4.5-6.el6.src.rpm
226 Directory send OK.
ftp>

Comment 2 James Antill 2011-07-07 16:16:38 UTC

*** This bug has been marked as a duplicate of bug 710469 ***

Comment 3 Akemi Yagi 2011-09-01 08:15:06 UTC
** For people who get here through search **

Comment 6 of bug 710469 has a workaround:

https://bugzilla.redhat.com/show_bug.cgi?id=710469#c6

I edited the /etc/yum.repos.d/rhel-source.repo file and changed:

[rhel-source]

to

[rhel-x86_64-server-6-source]

'yumdownloader --source' now works with this temporary fix.


Note You need to log in before you can comment on or make changes to this bug.