Bug 719679 - Sometimes, suspend on close-lid may be the best choice for a docked laptop
Sometimes, suspend on close-lid may be the best choice for a docked laptop
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 12:28 EDT by Paolo Bonzini
Modified: 2012-06-14 21:05 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-14 21:05:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 657201 None None None Never

  None (edit)
Description Paolo Bonzini 2011-07-07 12:28:44 EDT
Description of problem:
The default action for lid closing should be to suspend.  This works on my Thinkpad T500 when on battery and on AC, but not when docked.

Version-Release number of selected component (if applicable):
gnome-power-manager-3.0.0-3.fc15.x86_64
upower-0.9.10-1.fc15.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Put computer into docking station.
2. Close lid.
  
Actual results:
Nothing.

Expected results:
Computer is suspended.

Additional info:
acpi_listen output:
button/lid LID close
video/switchmode VMOD 00000080 00000000
button/lid LID open
processor LNXCPU:00 00000080 00000004
processor LNXCPU:00 00000080 00000000
processor LNXCPU:00 00000080 00000004
processor LNXCPU:01 00000080 00000004
processor LNXCPU:00 00000080 00000000
processor LNXCPU:01 00000080 00000000
processor LNXCPU:00 00000080 00000004
processor LNXCPU:01 00000080 00000004
Comment 1 Richard Hughes 2011-07-07 12:48:57 EDT
Yup, we explicitly disable suspend-on-lid closed when docked. Some people close the lid on the laptop and just use an external screeen. This is what the designers wanted.
Comment 2 Paolo Bonzini 2011-07-08 06:46:23 EDT
> Some people close the lid on the laptop and just use an external screeen. This > is what the designers wanted.

Is there a gconf setting to undo that?  If so, I can move the bug to gnome-tweak-tool (and perhaps even fix it myself).

Of course, it would be even better if the default behavior were conditional on having: 1) at least one active (possibly mirrored) external display; 2) one attached external keyboard.

In fact, "docked" seems to be a cheap replacement for this condition.  If a laptop is on AC power but has an external keyboard and display, and you close the lid, it should likely be blanked rather than suspended.
Comment 3 Paolo Bonzini 2011-07-08 06:52:52 EDT
Hmm, after more tests I found that something similar to what I mentioned in comment 2 _is_ implemented.  Probably another condition is required though, for example displays being mirrored, or the activities bar being on the external display.

In my case (external display+keyboard+mouse, but activities bar on the laptop screen) it is pretty obvious that I want to suspend the laptop, as the activities bar is not accessible anymore when I close the lid.
Comment 4 Paolo Bonzini 2011-11-02 10:31:38 EDT
How can I ask someone to look at the patch upstream? The use case in comment 1 just works with it too.
Comment 5 Matthias Clasen 2012-06-14 21:05:31 EDT
Fix was committed upstream

Note You need to log in before you can comment on or make changes to this bug.