Bug 719732 - [RHEL5.7][SELinux] avc: denied { sys_module } for pid=3008 comm="irqbalance"
[RHEL5.7][SELinux] avc: denied { sys_module } for pid=3008 comm="irqbalance"
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: selinux-policy (Show other bugs)
5.7
All Linux
medium Severity medium
: rc
: ---
Assigned To: Miroslav Grepl
Milos Malik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 15:23 EDT by PaulB
Modified: 2012-10-16 07:32 EDT (History)
7 users (show)

See Also:
Fixed In Version: selinux-policy-2.4.6-317.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-21 00:47:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description PaulB 2011-07-07 15:23:40 EDT
Description of problem:
 We recieved the following avc failure, while testing:
avc:  denied  { sys_module } for  pid=3008 comm="irqbalance" capability=16 scontext=system_u:system_r:irqbalance_t:s0 tcontext=system_u:system_r:irqbalance_t:s0 tclass=capability


Version-Release number of selected component (if applicable):
 RHEL5.7-Server-20110608.1_nfs-x86_64 	
 kernel-xen-2.6.18-266.el5

How reproducible:
 I was unable to reproduce this issue.
 
Actual results:
The following avc failure was seen while testing:
https://beaker.engineering.redhat.com/jobs/101390
http://beaker-archive.app.eng.bos.redhat.com/beaker-logs/2011/06/1013/101390/207107/2254574/10734459//test_log--distribution-virt-install-install_guest-80-21.rhts.eng.bos.redhat.com-avc.log
(http://tinyurl.com/5sj2o6d)
<-SNIP->
 type=SYSCALL msg=audit(1308873138.098:25): arch=c000003e syscall=16
 success=no exit=-19 a0=4 a1=8946 a2=7fff0d84c210 a3=7fff0d84c210
 items=0 ppid=1 pid=3008 auid=4294967295 uid=0 gid=0 euid=0 suid=0
 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295
 comm="irqbalance" exe="/usr/sbin/irqbalance"
 subj=system_u:system_r:irqbalance_t:s0 key=(null)
 type=AVC msg=audit(1308873138.098:25): avc:  denied  { sys_module } for
 pid=3008 comm="irqbalance" capability=16
 scontext=system_u:system_r:irqbalance_t:s0
 tcontext=system_u:system_r:irqbalance_t:s0 tclass=capability
 Fail: AVC messages found.
 Checking for errors...
<-SNIP->

Expected results:
 No failures.


Additional info:
 System hostname listed in following comment.
Comment 6 Miroslav Grepl 2011-09-29 07:30:43 EDT
Fixed in selinux-policy-2.4.6-317.el5
Comment 9 errata-xmlrpc 2012-02-21 00:47:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0158.html

Note You need to log in before you can comment on or make changes to this bug.