This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 719739 - subscription-manager orgs output isn't very descriptive
subscription-manager orgs output isn't very descriptive
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-07 16:05 EDT by J.C. Molet
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description J.C. Molet 2011-07-07 16:05:07 EDT
Description of problem:
The subscription-manager orgs output isn't very descriptive.  Currently it only gives the key values of the orgs, and does not give the org displayNames (which is info needed to use orgs in the gui).

Version-Release number of selected component (if applicable):
subscription-   manager-0.96.2-1.git.31.702703f.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. install subscription manager
2.  run `subscription-manager orgs`
  
Actual results:
This output looks like debug print statements accidently left in the code:

[root@jmolet-vm0 ~]# subscription-manager orgs --username=testuser1
Password:
orgs:
snowwhite
admin


Expected results:
The output should have the same form as `subscription-manager list`

[root@jmolet-vm0 ~]# subscription-manager orgs --username=testuser1
Password:

+------------------------------+
    testuser1 Organizations
+------------------------------+

OrgName:  Snow White
OrgKey:   snowwhite

OrgName:  Admin User
OrgKey:   admin

Additional info:  
This will allow me to use this command to make the connection between my org key (used in the cli) and my org displayName (used in the gui). This is especially useful if my orgs look like this:

OrgName:  Snow White
OrgKey:   admin

OrgName:  Juans Brown Sandwiches
OrgKey:   snowwhite


Also, if there are no orgs available, it should simply look like this:

subscription-manager orgs --username=testuser3
Password:
testuser3 is not a member of any organizations.
Comment 1 Devan Goodwin 2011-07-20 15:21:59 EDT
Fixed in subscription-manager.git: e65faae2c8c895335ff2f4528566da19120a039b

Slight deviation for the no orgs situation, technically this case is listing orgs you can *register* to. We don't really have the notion of being a member of an org anymore, just roles/permissions, some of which may just be read-only, and those wouldn't appear here.



Sample output:



$ sudo env PYTHONPATH=src src/subscription-manager orgs --username=testuser1 --password=password
+-------------------------------------------+
          testuser1 Organizations
+-------------------------------------------+

OrgName: 	Admin Owner              
OrgKey: 	admin                    

OrgName: 	Snow White               
OrgKey: 	snowwhite                



$ sudo env PYTHONPATH=src src/subscription-manager orgs --username=testuser3 --password=password
testuser3 cannot register to any organizations.
Comment 2 J.C. Molet 2011-07-21 11:54:56 EDT
Works beautifully, marking VERIFIED

subscription-manager-0.96.4-1.git.47.e65faae.el6.x86_64

[root@jmolet-vm0 subscription_manager]# subscription-manager orgs --username=testuser1 --password=password
+-------------------------------------------+
          testuser1 Organizations
+-------------------------------------------+

OrgName: 	Admin Owner              
OrgKey: 	admin                    

OrgName: 	Snow White               
OrgKey: 	snowwhite                




[root@jmolet-vm0 subscription_manager]# subscription-manager orgs --username=testuser3 --password=password
testuser3 cannot register to any organizations.
Comment 3 errata-xmlrpc 2011-12-06 12:22:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.