Bug 719762 - fsck.gfs2 reported statfs error after gfs2_grow
Summary: fsck.gfs2 reported statfs error after gfs2_grow
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel
Version: 6.2
Hardware: Unspecified
OS: Linux
medium
low
Target Milestone: rc
: ---
Assignee: Ben Marzinski
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On: 660661
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-07 22:02 UTC by Nate Straz
Modified: 2011-10-04 13:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 660661
Environment:
Last Closed: 2011-10-04 13:19:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Nate Straz 2011-07-07 22:02:18 UTC
+++ This bug was initially created as a clone of Bug #660661 +++

Description of problem:


While testing 707091 for RHEL 6.2, I believe I hit this bug.

Product versions:
gfs2-utils-3.0.12.1-5.el6.x86_64

Steps to reproduce:
Run gfs_fsck_stress -e grow_full

Actual Results:

SCENARIO - [grow_full]
Fill the file system then try to grow it
Creating 2G LV grow on buzz-04
Creating file system on /dev/fsck/grow with options '-p lock_dlm -j 5 -t buzzez:grow' on buzz-04
Device:                    /dev/fsck/grow
Blocksize:                 4096
Device Size                2.00 GB (524288 blocks)
Filesystem Size:           2.00 GB (524288 blocks)
Journals:                  5
Resource Groups:           8
Locking Protocol:          "lock_dlm"
Lock Table:                "buzzez:grow"
UUID:                      59c772c6-f329-dc7b-03ec-d3e14138c558

Mounting gfs2 /dev/fsck/grow on buzz-01 with opts ''
Mounting gfs2 /dev/fsck/grow on buzz-02 with opts ''
Mounting gfs2 /dev/fsck/grow on buzz-03 with opts ''
Mounting gfs2 /dev/fsck/grow on buzz-04 with opts ''
Mounting gfs2 /dev/fsck/grow on buzz-05 with opts ''
 - filling file system
 - wrote 54 files
Filesystem           1K-blocks      Used Available Use% Mounted on
/dev/mapper/fsck-grow
                       2096912   2096912         0 100% /mnt/fsck
Extending LV grow by +100G on buzz-04
Growing /dev/fsck/grow on buzz-04
FS: Mount Point: /mnt/fsck
FS: Device:      /dev/dm-3
FS: Size:        524288 (0x80000)
FS: RG size:     65533 (0xfffd)
DEV: Size:       26738688 (0x1980000)
The file system grew by 102400MB.
gfs2_grow complete.
 - write more into the new space
100+0 records in
100+0 records out
1048576000 bytes (1.0 GB) copied, 1.51232 s, 693 MB/s
Unmounting /mnt/fsck on buzz-01
Unmounting /mnt/fsck on buzz-02
Unmounting /mnt/fsck on buzz-03
Unmounting /mnt/fsck on buzz-04
Unmounting /mnt/fsck on buzz-05
Starting fsck of /dev/fsck/grow on buzz-04
fsck output in /tmp/gfs_fsck_stress.2356/1.grow_full/1.fsck-buzz-04.log
fsck.gfs2 of /dev/fsck/grow on buzz-04 took 5 seconds
fsck.gfs2 returned 1
fsck.gfs2 of /dev/fsck/grow on buzz-04 fixed some errors

$ cat /tmp/gfs_fsck_stress.2356/1.grow_full/1.fsck-buzz-04.log
Validating Resource Group index.
Level 1 rgrp check: Checking if all rgrp and rindex values are good.
(level 1 passed)
Found unlinked inode at 524287 (0x7ffff)
Unlinked inode has zero size
Block 524287 (0x7ffff) seems to be free space, but is marked as inode in the bitmap.
The bitmap was fixed.
Resource group counts updated
Inode count inconsistent: is 9 should be 8
The statfs file is wrong:

Current statfs values:
blocks:  26735428 (0x197f344)
free:    25954684 (0x18c097c)
dinodes: 83 (0x53)

Calculated statfs values:
blocks:  26735428 (0x197f344)
free:    25954685 (0x18c097d)
dinodes: 82 (0x52)
The statfs file was fixed.

Comment 1 Ben Marzinski 2011-08-17 17:08:37 UTC
I am able to recreate this with linux-2.6.32-164, but not linux-2.6.32-188, and looking at the linux-2.6.32-188 code, this patch has already been added. Do you want to retest and verify this yourself, or can I just close this CURRENT_RELEASE?

Comment 2 Nate Straz 2011-08-17 17:15:27 UTC
When was the patch included?  Was it included as part of another bug?

Comment 3 Ben Marzinski 2011-08-17 19:48:40 UTC
Looks like it was here.
https://bugzilla.redhat.com/show_bug.cgi?id=661048

So this clearly predates the problem.  The fix is definitely in linux-2.6.32-164.
Be that as it may, I'm still not able to recreate the problem on linux-2.6.32-188, although I don't have a reason for why.

Comment 4 Steve Whitehouse 2011-09-26 10:50:40 UTC
Nate, is this still a problem?

Comment 5 Nate Straz 2011-10-04 13:19:25 UTC
Nope, I did not hit this during my last regression run with kernel-2.6.32-201.el6.  Closing...


Note You need to log in before you can comment on or make changes to this bug.