Bug 719789 - [abrt] libreoffice-calc-3.3.3.1-1.fc15: rtl_uString_assign: Process /usr/lib64/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-calc-3.3.3.1-1.fc15: rtl_uString_assign: Process /usr/lib6...
Status: CLOSED DUPLICATE of bug 657807
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
15
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:9637ab6a076afec15b891d7876a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-07 21:08 EDT by Michael Cronenworth
Modified: 2011-07-11 02:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-11 02:32:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (21.38 KB, text/plain)
2011-07-07 21:08 EDT, Michael Cronenworth
no flags Details
File: maps (79.71 KB, text/plain)
2011-07-07 21:08 EDT, Michael Cronenworth
no flags Details
File: backtrace (117.54 KB, text/plain)
2011-07-07 21:08 EDT, Michael Cronenworth
no flags Details

  None (edit)
Description Michael Cronenworth 2011-07-07 21:08:07 EDT
abrt version: 2.0.3
architecture:   x86_64
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/scalc.bin -calc file:///home/jeff/Documents/Jeff/Investments/IRA%20Rollover/IRA%20-%202011.ods
comment:        Trying to save a spreadsheet after minor editing. Other spreadsheets work fine. The document that crashes is financially sensitive so I cannot hand it over.
component:      libreoffice
crash_function: rtl_uString_assign
executable:     /usr/lib64/libreoffice/program/scalc.bin
kernel:         2.6.38.8-32.fc15.x86_64
os_release:     Fedora release 15 (Lovelock)
package:        libreoffice-calc-3.3.3.1-1.fc15
reason:         Process /usr/lib64/libreoffice/program/scalc.bin was killed by signal 11 (SIGSEGV)
time:           Thu Jul  7 17:31:09 2011
uid:            500
username:       jeff

backtrace:      Text file, 120357 bytes
dso_list:       Text file, 21888 bytes
maps:           Text file, 81619 bytes

environ:
:ORBIT_SOCKETDIR=/tmp/orbit-jeff
:XDG_SESSION_ID=1
:HOSTNAME=falcon
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=2582
:GPG_AGENT_INFO=/tmp/keyring-jWbsJd/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2270-falcon-libreoffice-1_TIME812662
:HISTSIZE=1000
:XDG_SESSION_COOKIE=5b7fa93f201145547054dae800000006-1310077065.201725-402171532
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/tmp/keyring-jWbsJd
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=jeff
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64
:SSH_AUTH_SOCK=/tmp/keyring-jWbsJd/ssh
:USERNAME=jeff
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1390,unix/unix:/tmp/.ICE-unix/1390
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MAIL=/var/spool/mail/jeff
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/jeff/.local/bin:/home/jeff/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/jeff
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1382
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:HOME=/home/jeff
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=jeff
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zlt3mhZZvq,guid=0024a8885b67d2d9fbeb5e970000001f
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/jeff
:DISPLAY=:0.0
:G_BROKEN_FILENAMES=1
:XAUTHORITY=/var/run/gdm/auth-for-jeff-rHCwzT/database
:_=/usr/lib64/libreoffice/program/scalc.bin

var_log_messages:
:Jul  5 19:27:51 falcon kernel: [ 6526.199694] scalc.bin[2766]: segfault at 80 ip 0000003ddce4467e sp 00007fff3832fea0 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  5 19:27:52 falcon abrt[2789]: saved core dump of pid 2766 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-05-19:27:51-2766.new/coredump (116125696 bytes)
:Jul  5 19:32:47 falcon kernel: [ 6822.101723] scalc.bin[2824]: segfault at 80 ip 0000003ddce4467e sp 00007fff7d14d740 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  5 19:32:48 falcon abrt[3006]: saved core dump of pid 2824 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-05-19:32:47-2824.new/coredump (115806208 bytes)
:Jul  5 19:33:34 falcon kernel: [ 6869.396598] scalc.bin[3080]: segfault at 80 ip 0000003ddce4467e sp 00007fff7ad4fb90 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  5 19:33:35 falcon abrt[3103]: saved core dump of pid 3080 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-05-19:33:34-3080.new/coredump (116252672 bytes)
:Jul  5 19:33:55 falcon kernel: [ 6890.505298] scalc.bin[3132]: segfault at 80 ip 0000003ddce4467e sp 00007fff0f514df0 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  5 19:33:56 falcon abrt[3151]: saved core dump of pid 3132 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-05-19:33:55-3132.new/coredump (116518912 bytes)
:Jul  6 15:39:39 falcon kernel: [12354.584726] scalc.bin[5286]: segfault at 80 ip 0000003ddce4467e sp 00007fff8d8147c0 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  6 15:39:40 falcon abrt[5307]: saved core dump of pid 5286 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-06-15:39:39-5286.new/coredump (116260864 bytes)
:Jul  6 15:42:57 falcon kernel: [12552.977367] scalc.bin[5387]: segfault at 80 ip 0000003ddce4467e sp 00007fffbfe52d20 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  6 15:42:59 falcon abrt[5416]: saved core dump of pid 5387 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-06-15:42:57-5387.new/coredump (150282240 bytes)
:Jul  6 15:43:46 falcon kernel: [12602.144523] scalc.bin[5527]: segfault at 80 ip 0000003ddce4467e sp 00007fff73f0a940 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  6 15:43:47 falcon abrt[5545]: saved core dump of pid 5527 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-06-15:43:46-5527.new/coredump (115195904 bytes)
:Jul  6 15:44:34 falcon kernel: [12649.965876] scalc.bin[5580]: segfault at 80 ip 0000003ddce4467e sp 00007fff90f4e910 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  6 15:44:36 falcon abrt[5606]: saved core dump of pid 5580 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-06-15:44:34-5580.new/coredump (116072448 bytes)
:Jul  7 17:29:51 falcon kernel: [  757.757002] scalc.bin[2533]: segfault at 80 ip 0000003ddce4467e sp 00007fff5188fe90 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  7 17:29:53 falcon abrt[2556]: saved core dump of pid 2533 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-07-17:29:51-2533.new/coredump (149553152 bytes)
:Jul  7 17:31:09 falcon kernel: [  836.218647] scalc.bin[2594]: segfault at 80 ip 0000003ddce4467e sp 00007fff2f8eb8f0 error 4 in libuno_sal.so.3[3ddce00000+1c9000]
:Jul  7 17:31:11 falcon abrt[2622]: saved core dump of pid 2594 (/usr/lib64/libreoffice/program/scalc.bin) to /var/spool/abrt/ccpp-2011-07-07-17:31:09-2594.new/coredump (160661504 bytes)
Comment 1 Michael Cronenworth 2011-07-07 21:08:11 EDT
Created attachment 511823 [details]
File: dso_list
Comment 2 Michael Cronenworth 2011-07-07 21:08:19 EDT
Created attachment 511824 [details]
File: maps
Comment 3 Michael Cronenworth 2011-07-07 21:08:29 EDT
Created attachment 511825 [details]
File: backtrace
Comment 4 Caolan McNamara 2011-07-08 05:35:03 EDT
hard enough to see from the crash where the problem was introduced, any chance of getting a smaller-non sensitive reproducer, or email me privately something that makes this happen.
Comment 5 David Tardon 2011-07-11 02:32:40 EDT

*** This bug has been marked as a duplicate of bug 657807 ***

Note You need to log in before you can comment on or make changes to this bug.