Bug 71980 - Kickstart 7.3: %packages parameters causes crash
Summary: Kickstart 7.3: %packages parameters causes crash
Status: CLOSED DUPLICATE of bug 71115
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.3
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-08-20 15:39 UTC by Thomas Clemen
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 18:49:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kickstart file reproducing problem (756 bytes, text/plain)
2002-08-20 15:42 UTC, Thomas Clemen
no flags Details
This works (772 bytes, text/plain)
2002-08-22 08:43 UTC, Thomas Clemen
no flags Details
This does not work (774 bytes, text/plain)
2002-08-22 08:44 UTC, Thomas Clemen
no flags Details
Formatting newlines work without --resolvedeps (760 bytes, text/plain)
2002-08-22 08:46 UTC, Thomas Clemen
no flags Details

Description Thomas Clemen 2002-08-20 15:39:48 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.0) Gecko/20020529

Description of problem:
When using %packages --resolvedeps in my kickstart file for RedHat 7.3,
anaconda crashes with signal 11 and immediately boots. There are no
suspicious log messages on vt3/vt4.  %packages --ignoredeps crashes
as well, and so does %packages --anystring.  Using %packages without
parameters works fine, but prompts default non-automatic behaviour
during install.Chosing "resolve dependancies" in this stage works.

The box is a PIII 800 Mhz with ide-disks. I use http install. 
Kickstart file is attached.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Use kickstart file with %packages parameters
	

Actual Results:  Immediate "install exited abnormally -- received signal 11"
from Anaconda. DHCP, Retrieval of kickstartfile and loading of modules completed
as expected. 

Additional info:

Comment 1 Thomas Clemen 2002-08-20 15:42:11 UTC
Created attachment 71624 [details]
kickstart file reproducing problem

Comment 2 Jeremy Katz 2002-08-21 05:42:50 UTC
Your kickstart config doesn't happen to have any dos newlines in it, does it?
(can't depend on html upload to not corrupt those :/)

Comment 3 Thomas Clemen 2002-08-21 12:35:04 UTC
That was one of my initial thoughts as well, but a quick run though 'od -b' does
not reveal any dos newlines. Are there any other special chars I should look
for?(typically ones invisible to emacs in shell-script mode).


Comment 4 Thomas Clemen 2002-08-22 08:42:27 UTC
Slight Ooops on my part, as the attached kickstart file does not reproduce the
problem. A couple of %post commands were left out due to an oversight in my m4
compilation - mera culpa.
I have now determined what exactly makes anaconda choke. The missing %post lines
contained \\n (backslash newline) for formatting. This produces the error
whenever %packages is used with a parameter.
Further attachments folllow.

Comment 5 Thomas Clemen 2002-08-22 08:43:36 UTC
Created attachment 72207 [details]
This works

Comment 6 Thomas Clemen 2002-08-22 08:44:20 UTC
Created attachment 72208 [details]
This does not work

Comment 7 Thomas Clemen 2002-08-22 08:46:12 UTC
Created attachment 72209 [details]
Formatting newlines work without --resolvedeps

Comment 8 Mike McLean 2003-01-02 23:45:58 UTC
This bug has been inappropriately marked MODIFIED. Please review the bug life
cycle information at 
http://bugzilla.redhat.com/bugzilla/bug_status.cgi

This is a duplicate.

*** This bug has been marked as a duplicate of 71115 ***

Comment 9 Red Hat Bugzilla 2006-02-21 18:49:26 UTC
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.


Note You need to log in before you can comment on or make changes to this bug.