Bug 719832 - RFE: support git for distributed sets
RFE: support git for distributed sets
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
future
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
: FutureFeature
: 864226 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 02:19 EDT by Jeff Fearn
Modified: 2016-06-17 17:07 EDT (History)
3 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2011-07-08 02:19:01 EDT
GIT is the new black, so it'd be nice to be able to use git for distributed sets.
Comment 2 Jeff Fearn 2013-05-30 00:49:04 EDT
http://search.cpan.org/dist/VCI/
Comment 3 Jeff Fearn 2013-09-30 21:34:18 EDT
*** Bug 864226 has been marked as a duplicate of this bug. ***
Comment 4 HSS Product Manager 2013-09-30 21:47:33 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 5 Ruediger Landmann 2013-09-30 23:19:16 EDT
Hi Jarek -- do you or your team have (or can easily make) a distributed <set> in Git so that we can test this functionality? Any pointers appreciated! :D
Comment 6 Jeff Fearn 2013-10-01 00:43:30 EDT
First shot checked in, without a set to test on so buyer beware.

Edit your publican.cfg like this:

books: "book1 book2"
repo: '"book1=git://git.example.org/book1.git""book2=git://git.example.com/git/book2.git"'

Assumption: each books is the only thing in the repository, so cd $book gets you to the books root directory

To ssh://git.fedorahosted.org/git/publican.git
   3bae3f8..d66841d  HEAD -> devel
Comment 8 Jeff Fearn 2013-10-10 21:53:31 EDT
Fixed bug where scm was getting truncated and failing to clone.

To ssh://git.fedorahosted.org/git/publican.git
   6416dd7..19e3915  HEAD -> devel
Comment 11 Jeff Fearn 2013-10-17 02:13:15 EDT
Added missing wrapper for dirmove.

Was able to build test set after removing Revision_History.xml from set's main file. Appendix is lot legal in a set.

To ssh://git.fedorahosted.org/git/publican.git
   f2ec67c..63e0a8f  HEAD -> devel
Comment 12 Jaromir Hradilek 2013-10-17 09:46:23 EDT
Thank you very much, Jeff.

Verified with publican-3.9.9-0.fc19.t11.noarch, commit 63e0a8f.

Note You need to log in before you can comment on or make changes to this bug.