Bugzilla will be upgraded to version 5.0 on a still to be determined date in the near future. The original upgrade date has been delayed.
Bug 71985 - redhat-config-packages fails to start
redhat-config-packages fails to start
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-config-packages (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 11:52 EDT by Carlos Morgado
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-21 10:17:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Morgado 2002-08-20 11:52:06 EDT
Description of Problem:

redhat-config-packages fails to start.
it dies:
# redhat-config-packages 
Traceback (most recent call last):
  File "/usr/share/redhat-config-packages/MainWindow.py", line 134, in ?
    im = method.CdromInstallMethod()
  File "/usr/share/redhat-config-packages/method.py", line 323, in __init__
    discid.read(self.baseDir + "/.discinfo")
  File "/usr/lib/python2.2/site-packages/rhpl/discid.py", line 30, in read
    file = open (filename, 'r')
IOError: [Errno 2] No such file or directory: '/usr/share/comps/i386/.discinfo'

the machine is cdrom-less.
Comment 1 Jeremy Katz 2002-08-21 02:37:09 EDT
Did you do an install via ftp/http?
Comment 2 Carlos Morgado 2002-08-21 04:46:01 EDT
yes, booted bootnet from floppy and did a ftp install.

Comment 3 Jeremy Katz 2002-08-21 10:04:25 EDT
Grab RedHat/base/comps.rpm and install it and things will be happier; there was
a bug in the code pulling the package for ftp/http installs that didn't get
fixed for (null).  Some better error handling is needed for this case, though.
Comment 4 Carlos Morgado 2002-08-21 10:17:21 EDT
the fix works for me.
Comment 5 Jeremy Katz 2002-08-24 17:00:17 EDT
And we now pop up an error dialog in this case instead of tracebacking as well

Note You need to log in before you can comment on or make changes to this bug.