Bug 719874 - perl-threads-lite keeps hanging during self checks
Summary: perl-threads-lite keeps hanging during self checks
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-threads-lite
Version: rawhide
Hardware: powerpc
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
: 1249149 (view as bug list)
Depends On:
Blocks: ARM64, F-ExcludeArch-aarch64
TreeView+ depends on / blocked
 
Reported: 2011-07-08 09:13 UTC by Karsten Hopp
Modified: 2018-04-13 14:16 UTC (History)
5 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2018-04-13 14:16:17 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 69354 None None None Never

Description Karsten Hopp 2011-07-08 09:13:05 UTC
Description of problem:
During a mass rebuild on PPC and PPC64, perl-threads-lite-0.031-2.fc16 gets
stuck while doing self checks on ppc. ppc64 completed the build just fine.
I have to either cancel the job or wait until mock gets a timeout.

Here's where it is hanging:
# Testing threads::lite 0.031, Perl 5.012003, /usr/bin/perl
t/00-load.t ....... ok
t/10-basics.t ..... 
Failed 5/6 subtests 

Version-Release number of selected component (if applicable):
perl-threads-lite-0.031-2.fc16

Actual results:
http://ppc.koji.fedoraproject.org/koji/taskinfo?taskID=249482

Note how ppc64 completed the build within 2 minutes and ppc was still working on it after more than 9 hours when I've canceled the job.

Comment 1 Petr Pisar 2011-07-08 10:31:46 UTC
Subtests 2--5 in t/10-basics.t fails (inter-thread message queue) and the only subtest in t/11-input.t dead-locks.

I will pass the problem to upstream, however don't be disappointed. Upstream usually lacks of specific hardware and it usually blame us that Fedora does not package perl well. OTOH this package has not yet been tested on ppc according <http://matrix.cpantesters.org/?dist=threads-lite%200.031;reports=1;os=linux;perl=5.12.3>.

I can exclude ppc architecture from this package as a quick work-around.

Comment 2 Fedora Update System 2012-02-25 10:53:47 UTC
perl-threads-lite-0.031-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/perl-threads-lite-0.031-5.fc17

Comment 3 Fedora Update System 2012-02-25 19:17:34 UTC
Package perl-threads-lite-0.031-6.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-threads-lite-0.031-6.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2431/perl-threads-lite-0.031-6.fc17
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-03-13 18:29:45 UTC
perl-threads-lite-0.031-6.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 5 Petr Pisar 2015-08-03 08:46:42 UTC
*** Bug 1249149 has been marked as a duplicate of this bug. ***

Comment 6 Petr Pisar 2015-08-03 08:48:26 UTC
The same issue on AArch64.

Comment 7 Petr Pisar 2015-08-03 09:06:31 UTC
I will disable the tests in all Fedora releases for AArch64 too and I will remove this package from affected platforms in rawhide.

Comment 8 Fedora Update System 2015-08-03 09:12:59 UTC
perl-threads-lite-0.034-4.fc23 has been submitted as an update for Fedora 23.
https://admin.fedoraproject.org/updates/perl-threads-lite-0.034-4.fc23

Comment 9 Fedora Update System 2015-08-03 09:13:14 UTC
perl-threads-lite-0.034-2.fc22 has been submitted as an update for Fedora 22.
https://admin.fedoraproject.org/updates/perl-threads-lite-0.034-2.fc22

Comment 10 Fedora Update System 2015-08-03 09:13:33 UTC
perl-threads-lite-0.034-2.fc21 has been submitted as an update for Fedora 21.
https://admin.fedoraproject.org/updates/perl-threads-lite-0.034-2.fc21

Comment 11 Petr Pisar 2015-08-03 10:56:24 UTC
The architectures were disabled in perl-threads-lite-0.034-5.fc24.

Comment 12 Fedora Update System 2015-08-03 16:51:31 UTC
Package perl-threads-lite-0.034-4.fc23:
* should fix your issue,
* was pushed to the Fedora 23 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing perl-threads-lite-0.034-4.fc23'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2015-12672/perl-threads-lite-0.034-4.fc23
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2015-08-10 10:05:17 UTC
perl-threads-lite-0.034-4.fc23 has been pushed to the Fedora 23 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2015-08-25 01:55:58 UTC
perl-threads-lite-0.034-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2015-08-25 03:47:21 UTC
perl-threads-lite-0.034-2.fc21 has been pushed to the Fedora 21 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2018-03-08 09:17:27 UTC
perl-threads-lite-0.034-13.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-95f1522681

Comment 17 Fedora Update System 2018-03-08 15:30:07 UTC
perl-threads-lite-0.034-13.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-95f1522681

Comment 18 Fedora Update System 2018-03-30 12:46:12 UTC
perl-threads-lite-0.034-13.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.