Bug 719892 - [RFE]: NM should yield if user has insufficient permissions for wifi sharing
Summary: [RFE]: NM should yield if user has insufficient permissions for wifi sharing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Dan Williams
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-07-08 10:25 UTC by Vladimir Benes
Modified: 2012-06-20 13:42 UTC (History)
3 users (show)

Fixed In Version: NetworkManager-0.8.1-22.el6
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-06-20 13:42:23 UTC
Target Upstream Version:


Attachments (Terms of Use)
show notification with failure message (838 bytes, patch)
2012-03-01 13:31 UTC, Jirka Klimes
no flags Details | Diff
error message screenshot (28.79 KB, image/png)
2012-03-01 13:32 UTC, Jirka Klimes
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0832 normal SHIPPED_LIVE NetworkManager bug fix and enhancement update 2012-06-19 20:49:16 UTC

Description Vladimir Benes 2011-07-08 10:25:23 UTC
Description of problem:
When I forbid wireless sharing by setting no in /usr/share/polkit-1/actions/org.freedesktop.network-manager-settings.system.policy 

NM looks like it should work but nothing happens.. silent failure.. this behavior should be better .. some dialog should be shown 

Version-Release number of selected component (if applicable):
NetworkManager-0.8.1-9.el6_1.1.i686

How reproducible:


Steps to Reproduce:
1. forbid wireless sharing as stated here: https://bugzilla.redhat.com/show_bug.cgi?id=709662#c1 (use no instead of admin_auth)
2. create wireless network

  
Actual results:
creating of wireless correctly fails but no message to user provided

Expected results:
should show something like.. Creation of wireless network denied.. contact system administrator for help.. :)

Additional info:

Comment 4 Jirka Klimes 2012-03-01 13:31:45 UTC
Created attachment 566848 [details]
show notification with failure message

Comment 5 Jirka Klimes 2012-03-01 13:32:52 UTC
Created attachment 566849 [details]
error message screenshot

Comment 9 errata-xmlrpc 2012-06-20 13:42:23 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0832.html


Note You need to log in before you can comment on or make changes to this bug.