Bug 71993 - Spurious "A" characters in release notes title in install
Spurious "A" characters in release notes title in install
Status: CLOSED RAWHIDE
Product: Red Hat Public Beta
Classification: Retired
Component: redhat-release (Show other bugs)
null
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Powers
:
Depends On:
Blocks: 67217
  Show dependency treegraph
 
Reported: 2002-08-20 12:33 EDT by Telsa Gwynne
Modified: 2008-05-01 11:38 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 01:36:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Telsa Gwynne 2002-08-20 12:33:23 EDT
Description of Problem:

graphical install of 'null'. Hit the 'release notes' button.

The second line of the release notes box thrown up says copyrightA(c),
where the (c) is the © symbol and the A is a capital A with
a hat on it. 

This A-hat symbol recurs further down, seemingly in front of list items
in the RAID section of the notes, and in front of list items in the section
about Unicode, GNOME, gcc, java compiler... actually as I go down this
list it looks like all but that first one are list items within list
items.
Comment 1 Tim Powers 2002-08-20 12:35:31 EDT
Yep, I've seen this as well. I'm copying Jeremy and Tammy, maybe they have some
clue as to what's happening.

Tim
Comment 2 Tammy Fox 2002-08-20 12:45:52 EDT
It doesn't look like the A character is in the HTML file. Maybe there
is a bug in the way anaconda renders it? I'm changing the component
to anaconda.
Comment 3 Jeremy Katz 2002-08-21 01:47:36 EDT
I think that the problem is that the copyright symbol as included isn't a valid
UTF-8 character and it really should be using the © entity instead.  Ideas
from the docbook gallery on how to actually get this to occur? :)

For the weird symbols lower down, it looks like we're getting output with the
bullet symbol + paragraphs as opposed to an unordered list.
Comment 4 Tim Waugh 2002-08-21 03:06:49 EDT
0x00A9 (which is what it is) displays fine here. 
 
I think the problem is the conversion from HTML to text---if you ask for 
UTF-8, you get UTF-8.  Our RELEASE-NOTES.txt displays fine on a UTF-8 terminal 
here, but looks awful as ASCII. 
 
Why aren't we using ASCII, at least for English versions?
Comment 5 Jeremy Katz 2002-08-22 01:21:59 EDT
Okay, html appears to be viewing properly with current trees.  We still need to
decide what we want to do about the text versions.
Comment 6 Bill Nottingham 2002-08-22 01:36:38 EDT
We should probably just do the text as some sort of native encoding.
Comment 7 Matt Wilson 2002-08-23 18:51:08 EDT
Fixed in next build

Note You need to log in before you can comment on or make changes to this bug.