This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 719990 - while navigating Resource tree, globally un-caught exception "JavaScriptException:(TypeError): _6 is undefined" in isc_TabSet_updateTab()
while navigating Resource tree, globally un-caught exception "JavaScriptExcep...
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
All All
urgent Severity high (vote)
: ---
: ---
Assigned To: Jay Shaughnessy
Mike Foley
:
: 728358 (view as bug list)
Depends On:
Blocks: rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-08 11:47 EDT by Mike Foley
Modified: 2012-02-07 14:30 EST (History)
4 users (show)

See Also:
Fixed In Version: 4.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:29:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mike Foley 2011-07-08 11:47:00 EDT
Description of problem:  AS7 Plugin, Globally un-caught exception while navigating resources in the resource tree


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  Navigation of AS7 resource, expanding/collapsing sub-systems
2.
3.
  
Actual results:

Globally uncaught exception
Severity :	
Error
	
Time :	
Friday, July 8, 2011 11:38:13 AM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): _6 is undefined stack: isc_TabSet_updateTab([object Object],null)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Containers.js:387 com_smartgwt_client_widgets_tab_TabSet_$updateTab__Lcom_smartgwt_client_widgets_tab_TabSet_2Lcom_smartgwt_client_widgets_tab_Tab_2Lcom_smartgwt_client_widgets_Canvas_2V([object Object],[object Object],null)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:24746 org_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_$setTabHidden__Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZV([object Object],[object Object],true)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:81509 org_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_$updateTab__Lorg_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZZZ([object Object],[object Object],false,true)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:117773 org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_$updateTabContent__Lorg_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_2Lorg_rhq_core_domain_resource_group_composite_ResourceGroupComposite_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:123642 org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView$18_onTypesLoaded__Lorg_rhq_core_domain_resource_ResourceType_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:124071 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$3_onTypesLoaded__Ljava_util_Map_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142022 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_2Lorg_rhq_core_domain_util_PageList_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142098 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142110 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:9294 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:151972 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:4378 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:12598 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Containers.js lineNumber: 387
--- STACK TRACE FOLLOWS ---
(TypeError): _6 is undefined stack: isc_TabSet_updateTab([object Object],null)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Containers.js:387 com_smartgwt_client_widgets_tab_TabSet_$updateTab__Lcom_smartgwt_client_widgets_tab_TabSet_2Lcom_smartgwt_client_widgets_tab_Tab_2Lcom_smartgwt_client_widgets_Canvas_2V([object Object],[object Object],null)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:24746 org_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_$setTabHidden__Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZV([object Object],[object Object],true)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:81509 org_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_$updateTab__Lorg_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZZZ([object Object],[object Object],false,true)@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:117773 org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_$updateTabContent__Lorg_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_2Lorg_rhq_core_domain_resource_group_composite_ResourceGroupComposite_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:123642 org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView$18_onTypesLoaded__Lorg_rhq_core_domain_resource_ResourceType_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:124071 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$3_onTypesLoaded__Ljava_util_Map_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142022 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_2Lorg_rhq_core_domain_util_PageList_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142098 org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:142110 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:9294 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:151972 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:4378 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:12598 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DA30B4C85EE0D5F742EB876A4ACA650C.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/sc/modules/ISC_Containers.js lineNumber: 387
    at Unknown.isc_TabSet_updateTab(Unknown source:0)
    at Unknown.com_smartgwt_client_widgets_tab_TabSet_$updateTab__Lcom_smartgwt_client_widgets_tab_TabSet_2Lcom_smartgwt_client_widgets_tab_Tab_2Lcom_smartgwt_client_widgets_Canvas_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_$setTabHidden__Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTabSet_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZV(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_$updateTab__Lorg_rhq_enterprise_gui_coregui_client_inventory_common_detail_AbstractTwoLevelTabSetView_2Lorg_rhq_enterprise_gui_coregui_client_components_tab_TwoLevelTab_2ZZZ(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_$updateTabContent__Lorg_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView_2Lorg_rhq_core_domain_resource_group_composite_ResourceGroupComposite_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_ResourceGroupDetailView$18_onTypesLoaded__Lorg_rhq_core_domain_resource_ResourceType_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$3_onTypesLoaded__Ljava_util_Map_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_2Lorg_rhq_core_domain_util_PageList_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_type_ResourceTypeRepository$4_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.handleEvent(Unknown source:0)
    at Unknown.SJOWContentBoundary(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)


Expected results:


Additional info:
Comment 1 Heiko W. Rupp 2011-07-09 03:46:29 EDT
This is a GWT UI issue and not an as7plugin issue
Comment 2 Charles Crouch 2011-08-11 16:33:20 EDT
These bugs are all in the same general area of the resource tree, but with slightly different causes it would appear:

https://bugzilla.redhat.com/buglist.cgi?bug_id=728358,720038,719990,728356,728352
Comment 3 Ian Springer 2011-08-11 17:33:42 EDT
*** Bug 728358 has been marked as a duplicate of this bug. ***
Comment 4 Jay Shaughnessy 2011-08-17 10:47:57 EDT
Master commit: b06d1811c26d285ca30101bcb3b8d775951da2b1

Try fast clicking the resource tree, including autogroup nodes.
Comment 5 Jay Shaughnessy 2011-08-17 11:02:00 EDT
Actually, it's commit f0227303da27805124adf2c60766faaa236c1f55 but they all went in together.
Comment 6 Venkat 2011-08-18 07:23:12 EDT
I tired to replicate the BZ by following above steps with AS 7 environment, there is nor more exception now by navigating, expanding and collapsing the subsystems.

Verified on standalone mode and domain mode of AS7
Comment 7 Mike Foley 2012-02-07 14:29:47 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE
Comment 8 Mike Foley 2012-02-07 14:30:24 EST
marking VERIFIED BZs to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.