Bug 719999 - AS7 Plugin, Runtime exception clicking Configuration tab
AS7 Plugin, Runtime exception clicking Configuration tab
Status: CLOSED DUPLICATE of bug 719731
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.1
All All
high Severity medium (vote)
: ---
: ---
Assigned To: Heiko W. Rupp
Mike Foley
: Reopened
Depends On:
Blocks: rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-08 12:20 EDT by Mike Foley
Modified: 2011-08-17 13:02 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 13:02:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Globally uncaught exception clicking config tab (48.99 KB, image/png)
2011-08-12 11:47 EDT, Mike Foley
no flags Details
globally uncaught exception clicking config tab on 08/15 (78.30 KB, image/png)
2011-08-15 09:59 EDT, Mike Foley
no flags Details

  None (edit)
Description Mike Foley 2011-07-08 12:20:05 EDT
Description of problem:  AS7 Plugin, Runtime exception clicking Configuration tab


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.  AS7 plugin
2.  Click Configuration tab
3.
  
Actual results:
runtime exception

Expected results:
no runtime exceptin

Additional info:
Globally uncaught exception
Severity :	
Error
	
Time :	
Friday, July 8, 2011 12:16:58 PM Etc/GMT+4
Detail :	
java.lang.RuntimeException:One or more null or empty member connection settings was returned by the Server.
--- STACK TRACE FOLLOWS ---
One or more null or empty member connection settings was returned by the Server.
    at Unknown.java_lang_RuntimeException_$RuntimeException__Ljava_lang_RuntimeException_2Ljava_lang_String_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_2Ljava_util_Map_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.handleEvent(Unknown source:0)
    at Unknown.SJOWContentBoundary(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 1 Heiko W. Rupp 2011-08-12 11:19:59 EDT
Can not reproduce - please provide better steps.

Also note that the stacktrace is all from GWT , so I do not consider this an as7plugin bug.
Comment 2 Mike Foley 2011-08-12 11:40:54 EDT
reproduced RHQ 4.1 beta.  attaching screenshot.  the steps to reproduce are:  1) discover and inventory AS7, 2) click configuration tab (see attached screenshot), 3) observe globablly uncaught exception.


if it is a smartGWT issue, please assign appropriately.



Globally uncaught exception
Severity :	
Error
	
Time :	
Friday, August 12, 2011 11:36:58 AM Etc/GMT+4
Detail :	
com.google.gwt.core.client.JavaScriptException:(TypeError): this.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_val$result is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:141353 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:156751 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html lineNumber: 141353
--- STACK TRACE FOLLOWS ---
(TypeError): this.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_val$result is null stack: org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V([object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:141353 com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:9371 org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:156751 com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V([object Object],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:4380 com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V([object XMLHttpRequest])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:4604 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:12675 com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2((function () {handler.onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(_this);}),[object XMLHttpRequest],[object Object])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:2474 ([object Event])@http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html:2463 handleEvent([object Event])@:0 SJOWContentBoundary()@:0 fileName: http://localhost:7080/coregui/org.rhq.enterprise.gui.coregui.CoreGUI/DD34E7176C52CBC46E6A820C22A29DF3.cache.html lineNumber: 141353
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_resource_detail_configuration_ResourceConfigurationEditView$2$1$1_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_$onResponseReceived__Lcom_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_2Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.handleEvent(Unknown source:0)
    at Unknown.SJOWContentBoundary(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 3 Mike Foley 2011-08-12 11:47:41 EDT
Created attachment 518052 [details]
Globally uncaught exception clicking config tab
Comment 4 Heiko W. Rupp 2011-08-15 08:38:23 EDT
Can you please retry with as7 7.0.0.final or newer? As 7.0.CR1 is not supported.
Comment 5 Mike Foley 2011-08-15 09:54:42 EDT
could not reproduce RHQ 4.1 Beta with AS7 plugin from 8/15
Comment 6 Mike Foley 2011-08-15 09:59:45 EDT
Created attachment 518263 [details]
globally uncaught exception clicking config tab on 08/15
Comment 7 Mike Foley 2011-08-15 10:01:32 EDT
additional comment ... this is with 7.0.0 final.
Comment 8 Heiko W. Rupp 2011-08-16 11:15:33 EDT
Was able to provoke this when switching back from "history" to "current" subtab (not reliably though) 
with having two different versions of as7 having in inventory with the same management port setting, but different install path and one of the two being down.
   When I use two servers in different locations and different port setting and one being down, the UI reports that it can not obtain live config of all servers
When both resources are up again, I can provoke the exception and the server shows

17:13:00,270 INFO  [LiveConfigurationLoader] Loading live configs for 2 Resources...
17:13:00,311 INFO  [LiveConfigurationLoader] Loaded live configs for 2 Resources in 41 ms.
17:13:00,337 ERROR [ConfigurationManagerBean] Current Configuration for Resource[id=10571, type=JBossAS7-Standalone, key=/Users/hrupp/downloads/jboss-as-web-7.0.0.Final, name=snert, parent=snert] does not match latest associated ResourceConfigurationUpdate with SUCCESS status.

even if I have one click before updated(=read) the configuration on this as-web-700.

I suspect this is a timing error somewhere.


Message Center showed

java.lang.RuntimeException:One or more null or empty member connection settings was returned by the Server.
--- STACK TRACE FOLLOWS ---
One or more null or empty member connection settings was returned by the Server.
    at Unknown.com_google_gwt_core_client_impl_StackTraceCreator$Collector_fillInStackTrace__Ljava_lang_Throwable_2V(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_StackTraceCreator_fillInStackTrace__Ljava_lang_Throwable_2V(Unknown source:0)
    at Unknown.java_lang_Throwable_fillInStackTrace__Ljava_lang_Throwable_2(Unknown source:0)
    at Unknown.java_lang_Throwable_$$init__Ljava_lang_Throwable_2V(Unknown source:0)
    at Unknown.java_lang_Throwable_$Throwable__Ljava_lang_Throwable_2Ljava_lang_String_2Ljava_lang_Throwable_2(Unknown source:0)
    at Unknown.java_lang_Exception_$Exception__Ljava_lang_Exception_2Ljava_lang_String_2Ljava_lang_Exception_2(Unknown source:0)
    at Unknown.java_lang_RuntimeException_$RuntimeException__Ljava_lang_RuntimeException_2Ljava_lang_String_2Ljava_lang_RuntimeException_2(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_$onSuccess__Lorg_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_2Ljava_util_Map_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_inventory_groups_detail_configuration_GroupResourceConfigurationEditView$3$1_onSuccess__Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.com_google_gwt_user_client_rpc_impl_RequestCallbackAdapter_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.org_rhq_enterprise_gui_coregui_client_util_rpc_TrackingRequestCallback_onResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_Response_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_Request_$fireOnResponseReceived__Lcom_google_gwt_http_client_Request_2Lcom_google_gwt_http_client_RequestCallback_2V(Unknown source:0)
    at Unknown.com_google_gwt_http_client_RequestBuilder$1_onReadyStateChange__Lcom_google_gwt_xhr_client_XMLHttpRequest_2V(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_apply__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
Comment 9 Heiko W. Rupp 2011-08-16 11:28:16 EDT
The old UI does not support configurations for autogroups

For compatible group it shows "Viewing/editing of lists of properties is not yet supported for group Configurations. To.... "

Old UI puts that in the server log:

17:27:26,157 INFO  [LiveConfigurationLoader] Loading live configs for 2 Resources...
17:27:26,206 INFO  [LiveConfigurationLoader] Loaded live configs for 2 Resources in 49 ms.
17:27:26,371 ERROR [ConfigurationManagerBean] Current Configuration for Resource[id=10571, type=JBossAS7-Standalone, key=/Users/hrupp/downloads/jboss-as-web-7.0.0.Final, name=snert, parent=snert] does not match latest associated ResourceConfigurationUpdate with SUCCESS status.
17:27:26,418 INFO  [GroupResourceConfigurationUtility] Calculating group config for ResourceGroup[id=10051, name=as7, category=COMPATIBLE, type=JBossAS7-Standalone, isDynaGroup=false, isClusterGroup=false]...
17:27:26,478 INFO  [GroupResourceConfigurationUtility] Calculated group config in 59 ms.
Comment 10 John Mazzitelli 2011-08-17 13:02:40 EDT

*** This bug has been marked as a duplicate of bug 719731 ***

Note You need to log in before you can comment on or make changes to this bug.