Bug 72003 - rhn-applet does not show "connecting" green icon upon start
rhn-applet does not show "connecting" green icon upon start
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: rhn-applet (Show other bugs)
7.3
i386 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Beth Nackashi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 13:15 EDT by Oliver Schulze L.
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-07 12:22:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Schulze L. 2002-08-20 13:15:24 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.0.0) Gecko/20020530

Description of problem:
When you run rhn-applet, the "Checking for updates" icon does
not appears while doing the first check as documented in
the doc page:
/usr/share/doc/rhn-applet-1.0.6/applet-notification-icons.html

The tooltip is updated correctly, but not the icon. Instead, 
an "System is up-to-date" blue icon is showed when the tooltip
says "Waiting until first checking" and "Checking RHN for updates" 

This green icon only appears if you manually request a "check for updates"
via the right button.

How reproducible:
Always

Steps to Reproduce:
1. run rhn-applet
2. put the mouse over the applet to see the tooltip
Comment 1 Chip Turner 2002-08-29 12:01:45 EDT
it only shows that icon when you force it to check in because it becomes too
distracting to see it switch back and forth.  this behavior is intentional.
Comment 2 Oliver Schulze L. 2002-08-29 12:16:03 EDT
But it is not what the documentation says.
Also, a normal user will launch rhn-applet and then he will think
that the system is upated. But if he wait a minute or so, then he will
realize that the system is not updated.
The green icon at the program start will helps users and will be acting
like the documentation says.

I sugest to keep the green icon when rhn-applet starts until it determines
that the system updated or not updated.
Comment 3 Oliver Schulze L. 2002-09-19 10:24:07 EDT
I think it is not distracting, because when you launch an applet, you always
watch the applet to see what it is happening.
Comment 4 Chip Turner 2002-10-03 12:24:56 EDT
lowering priority.  will consider adding an option of '--check-now' to applet
startup in menu which will make it check and turn green at startup.

Note You need to log in before you can comment on or make changes to this bug.