This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720045 - subscription-manager repos formatting
subscription-manager repos formatting
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-08 16:20 EDT by John Sefler
Modified: 2011-12-06 12:22 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-08 16:20:28 EDT
Description of problem:
To be consistent with other subscription-manager command line output, I'd like to see the the output from subscription-manager repos modified...

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.2-1.git.31.702703f.el6.x86_64


 
Current stdout:
# subscription-manager repos --list
The system is entitled to the following repositories.
These can be managed at in the repo file /etc/yum.repos.d/redhat.repo.

RepoName:            	awesomeos-server-scalable-fs
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/path/to/awesomeos-server-scalable-fs
Enabled:             	1                        


RepoName:            	never-enabled-content    
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path/never
Enabled:             	0                        





Proposed stdout:
# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+

RepoName:               Awesome OS Scalable Filesystem Bits
RepoId:            	awesomeos-server-scalable-fs
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/path/to/awesomeos-server-scalable-fs
Enabled:             	1                        


RepoName:               never-enabled-content
RepoId:            	never-enabled-content    
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path/never
Enabled:             	0
Comment 1 Bryan Kearney 2011-07-11 17:02:11 EDT
Fixed in master at 8f93d7f9a844fa85f3b9a52c81c70d5650f3c10a.
Comment 3 John Sefler 2011-07-12 12:32:07 EDT
# subscription-manager repos --list
The system is entitled to the following repositories.
These can be managed at in the repo file /etc/yum.repos.d/redhat.repo.

RepoName:            	content                  
RepoId:              	content-label            
RepoUrl:             	https://mockamai.devlab.phx1.redhat.com/foo/path
Enabled:             	1     


^^^ The data looks good.
How about also changing the feedback message to a banner to be consistent with the other subscription-manager list functions?

Something like this would be nice...
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+


At a minimum, fix the grammar in...
These can be managed at in the repo file /etc/yum.repos.d/redhat.repo.
                     ^^

moving back to NEW
Comment 4 Bryan Kearney 2011-07-18 14:55:13 EDT
Fixed in a534d79098edff21fca2d10555ee9c1d369a9e50 in master.
Comment 5 John Sefler 2011-07-19 13:25:48 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.40.158de0a.el6.x86_64


[root@jsefler-onprem-62server ~]# subscription-manager repos --list
+----------------------------------------------------------+
    Entitled Repositories in /etc/yum.repos.d/redhat.repo
+----------------------------------------------------------+

RepoName:            	never-enabled-content    
RepoId:              	never-enabled-content    
RepoUrl:             	https://cdn.redhat.com/foo/path/never
Enabled:             	0                        


RepoName:            	always-enabled-content   
RepoId:              	always-enabled-content   
RepoUrl:             	https://cdn.redhat.com/foo/path/always
Enabled:             	1                        


RepoName:            	awesomeos-modifier       
RepoId:              	awesomeos-modifier       
RepoUrl:             	http://example.com/awesomeos-modifier
Enabled:             	1                        


RepoName:            	content                  
RepoId:              	content-label            
RepoUrl:             	https://cdn.redhat.com/foo/path
Enabled:             	1       

[root@jsefler-onprem-62server ~]# subscription-manager unsubscribe --all
[root@jsefler-onprem-62server ~]# subscription-manager repos --list
The system is not entitled to use any repositories
                                                  ^
             PUT A PERIOD AT THE END OF A SENTENCE.
Comment 6 Bryan Kearney 2011-07-19 13:34:51 EDT
fixed in 58e8e1c1513fc472cc7163deaf10e88f5eea1529 in master.
Comment 7 John Sefler 2011-07-26 13:41:23 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.4-1.git.63.7bb4765.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager repos --list
The system is not entitled to use any repositories.

moving to VERIFIED
Comment 8 errata-xmlrpc 2011-12-06 12:22:12 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html

Note You need to log in before you can comment on or make changes to this bug.