Bug 720049 - the proxy options should not be available to the subscription-manager repos command
the proxy options should not be available to the subscription-manager repos c...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bryan Kearney
John Sefler
:
Depends On:
Blocks: rhsm-rhel62
  Show dependency treegraph
 
Reported: 2011-07-08 16:45 EDT by John Sefler
Modified: 2013-12-05 09:21 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-06 12:22:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2011-07-08 16:45:18 EDT
Description of problem:
subscription-manager repos should not need to call the candlepin server and therefore should not need access to the --proxy options.

Version-Release number of selected component (if applicable):
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.2-1.git.31.702703f.el6.x86_64


How reproducible:


Steps to Reproduce:
[root@jsefler-onprem-62server ~]# subscription-manager repos --help
Usage: subscription-manager repos [OPTIONS]

List the repos which this machine is entitled to use

Options:
  -h, --help            show this help message and exit
  --proxy=PROXY_URL     proxy url in the form of proxy_hostname:proxy_port
  --proxyuser=PROXY_USER
                        user for http proxy with basic authentication
  --proxypassword=PROXY_PASSWORD
                        password for http proxy with basic authentication
  --list                list the entitled repositories for this system

  
^^^ REMOVE THE proxy OPTIONS
^^^ IN FACT, IF --list IS GOING TO BE THE ONLY OPTION, THEN WE REALLY DON'T NEED IT.  JUST REMOVE IT.


Expected results:
[root@jsefler-onprem-62server ~]# subscription-manager repos --help
Usage: subscription-manager repos [OPTIONS]

List the repositories that this machine is entitled to use

Options:
  -h, --help            show this help message and exit
Comment 1 Bryan Kearney 2011-07-11 14:20:26 EDT
Fixed in 
3526df9ebb4049a0cff04ab15b420d2e6574207b
Comment 3 John Sefler 2011-07-12 12:06:51 EDT
Verifying Version...
[root@jsefler-onprem-62server ~]# rpm -q subscription-manager
subscription-manager-0.96.3-1.git.33.8f93d7f.el6.x86_64

[root@jsefler-onprem-62server ~]# subscription-manager repos --help
Usage: subscription-manager repos [OPTIONS]

List the repos which this machine is entitled to use

Options:
  -h, --help  show this help message and exit
  --list      list the entitled repositories for this system
[root@jsefler-onprem-62server ~]# 

The proxy options have been removed.
Comment 4 errata-xmlrpc 2011-12-06 12:22:14 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2011-1695.html
Comment 5 John Sefler 2013-12-05 09:17:36 EST
Update...
This bug is wrong.  It should not have been opened and the fix in comment 1 should not have been applied.
Corrections to fix this bug have been processed by bug 909778 and bug 906642.

Note You need to log in before you can comment on or make changes to this bug.