Bug 720054 - dmesg shows usb disconnect and traceback on a Toshiba NB555D
dmesg shows usb disconnect and traceback on a Toshiba NB555D
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Josh Boyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-08 17:15 EDT by Peter H. Jones
Modified: 2011-08-22 10:50 EDT (History)
7 users (show)

See Also:
Fixed In Version: kernel-3.0.1-3.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-08-17 22:32:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output of dmesg command (63.22 KB, text/plain)
2011-07-08 17:15 EDT, Peter H. Jones
no flags Details
Output of dmesg command with test kernel (62.24 KB, text/plain)
2011-08-06 13:45 EDT, Peter H. Jones
no flags Details
dmesg output of kernel 3.0.1-3.fc16.x86_64 (60.84 KB, text/plain)
2011-08-09 11:48 EDT, Peter H. Jones
no flags Details
dmesg output of kernel 3.0.1-3.fc16.x86_64 with nomodest, pci=nocrs (57.93 KB, text/plain)
2011-08-09 11:51 EDT, Peter H. Jones
no flags Details

  None (edit)
Description Peter H. Jones 2011-07-08 17:15:18 EDT
Created attachment 511996 [details]
output of dmesg command

Call trace in dmesg during boot.

:

Version-Release number of selected component (if applicable):
Tried
kernel-3.0-0.rc6.git0.1.fc16.x86_64 andmdadm-3.2.2-3.fc16.x86_64


How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
Call trace

Expected results:


Additional info:
Comment 1 Yun-Fong Loh 2011-07-21 12:17:39 EDT
Might this be a duplicate of:

Bug 663186?
Comment 2 Josh Boyer 2011-08-01 17:00:16 EDT
(In reply to comment #1)
> Might this be a duplicate of:
> 
> Bug 663186?

I don't think so, no.  The backtraces are entirely different.  This looks more like a bug in the ums-realtek driver.  It's using stack variables to pass as DMA buffers, which is a no-no.
Comment 3 Josh Boyer 2011-08-02 09:45:48 EDT
Could you please test this kernel and let me know if it solves the stack trace?

http://koji.fedoraproject.org/koji/taskinfo?taskID=3246505
Comment 4 Peter H. Jones 2011-08-06 13:45:24 EDT
Created attachment 517000 [details]
Output of dmesg command with test kernel

Call trace is gone. However, I am observing the collision problem mentioned in bug 710715 , around line 237, since kernel version 3.
Comment 5 Fedora Update System 2011-08-08 20:04:39 EDT
kernel-3.0.1-3.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
Comment 6 Fedora Update System 2011-08-08 22:53:10 EDT
Package kernel-3.0.1-3.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.0.1-3.fc16'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/kernel-3.0.1-3.fc16
then log in and leave karma (feedback).
Comment 7 Peter H. Jones 2011-08-09 11:48:04 EDT
Created attachment 517435 [details]
dmesg output of kernel 3.0.1-3.fc16.x86_64

Still shows address space collision. Display locks after restarting from Hibernate.
Comment 8 Peter H. Jones 2011-08-09 11:51:08 EDT
Created attachment 517436 [details]
dmesg output of kernel 3.0.1-3.fc16.x86_64 with nomodest, pci=nocrs

Added pci=nocrs to get rid of address space collision, and pci=nocrs to avoid display lockup on return from Hibernate.
Comment 9 Fedora Update System 2011-08-16 08:47:12 EDT
kernel-2.6.40.3-0.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/kernel-2.6.40.3-0.fc15
Comment 10 Fedora Update System 2011-08-17 22:30:05 EDT
kernel-2.6.40.3-0.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2011-08-22 10:50:01 EDT
kernel-3.0.1-3.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.