This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 720063 - Clicking on link to a dynagroup definition sometimes throws exception
Clicking on link to a dynagroup definition sometimes throws exception
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Core UI (Show other bugs)
4.1
Unspecified Unspecified
low Severity unspecified (vote)
: ---
: ---
Assigned To: John Mazzitelli
Mike Foley
:
Depends On:
Blocks: jon30-bugs rhq41 rhq41-ui
  Show dependency treegraph
 
Reported: 2011-07-08 18:21 EDT by Charles Crouch
Modified: 2015-02-01 18:26 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:26:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Charles Crouch 2011-07-08 18:21:39 EDT
Description of problem:
When clicking on a link here:

http://jon06.mw.lab.eng.bos.redhat.com:7080/coregui/#Inventory/Groups/DynagroupDefinitions



Version-Release number of selected component (if applicable):
Ian's perf env

How reproducible:
2 out of 3 times so far

Steps to Reproduce:
1. Create dynagroup
2. View the lists of groups generated
3. Go back and try to view the dynagroup definition
  
Actual results:
In the message center you see this:
com.google.gwt.core.client.JavaScriptException:(TypeError): Cannot call method 'markForRedraw__V' of null
--- STACK TRACE FOLLOWS ---
(TypeError): Cannot call method 'markForRedraw__V' of null
    at Unknown.anonymous(Unknown source:0)
    at Unknown.at org_rhq_enterprise_gui_coregui_client_CoreGUI$RootCanvas_$renderView__Lorg_rhq_enterprise_gui_coregui_client_CoreGUI$RootCanvas_2Lorg_rhq_enterprise_gui_coregui_client_ViewPath_2V(Unknown source:0)
    at Unknown.at Object.org_rhq_enterprise_gui_coregui_client_CoreGUI_onValueChange__Lcom_google_gwt_event_logical_shared_ValueChangeEvent_2V [as onValueChange__Lcom_google_gwt_event_logical_shared_ValueChangeEvent_2V](Unknown source:0)
    at Unknown.at Object.com_google_gwt_event_logical_shared_ValueChangeEvent_dispatch__Lcom_google_gwt_event_shared_EventHandler_2V [as dispatch__Lcom_google_gwt_event_shared_EventHandler_2V](Unknown source:0)
    at Unknown.at com_google_gwt_event_shared_HandlerManager$HandlerRegistry_$fireEvent__Lcom_google_gwt_event_shared_HandlerManager$HandlerRegistry_2Lcom_google_gwt_event_shared_GwtEvent_2ZV(Unknown source:0)
    at Unknown.at com_google_gwt_event_shared_HandlerManager_$fireEvent__Lcom_google_gwt_event_shared_HandlerManager_2Lcom_google_gwt_event_shared_GwtEvent_2V(Unknown source:0)
    at Unknown.at Object.com_google_gwt_user_client_impl_HistoryImpl_fireEvent__Lcom_google_gwt_event_shared_GwtEvent_2V [as fireEvent__Lcom_google_gwt_event_shared_GwtEvent_2V](Unknown source:0)
    at Unknown.at com_google_gwt_event_logical_shared_ValueChangeEvent_fire__Lcom_google_gwt_event_logical_shared_HasValueChangeHandlers_2Ljava_lang_Object_2V(Unknown source:0)
    at Unknown.at Object.com_google_gwt_user_client_impl_HistoryImpl_newItemOnEvent__Ljava_lang_String_2V [as newItemOnEvent__Ljava_lang_String_2V](Unknown source:0)
    at Unknown.anonymous(Unknown source:0)
    at Unknown.at com_google_gwt_core_client_impl_Impl_entry0__Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2Ljava_lang_Object_2(Unknown source:0)


Expected results:
View the dynagroup definition

Additional info:
Comment 1 Charles Crouch 2011-08-10 23:55:47 EDT
Mike can you reproduce this? Any particular actions make it occur?
Comment 2 Mike Foley 2011-08-15 16:26:59 EDT
retested RHQ 4.1 on 8/15 on my local machine, and  could not repro.  
retested RHQ 4.? on 8/15 on perf env ... and could not repro.

perhaps it is one of the "quick click" issues, i am not able to repro following the bug loggers steps.
Comment 3 John Mazzitelli 2011-08-16 17:07:18 EDT
this might be a quick-click issue
Comment 4 John Mazzitelli 2011-08-18 13:27:41 EDT
I cannot reproduce this. I tried quick clicking around, too, to see if I can get it to happen and could not.
Comment 5 John Mazzitelli 2011-08-19 11:51:45 EDT
this does not seem to be a problem anymore - at least, I can't see it.
Comment 6 Mike Foley 2012-02-07 14:26:17 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.