Bug 720065 - Provide native systemd unit file
Summary: Provide native systemd unit file
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: zabbix (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: SysVtoSystemd
TreeView+ depends on / blocked
 
Reported: 2011-07-08 23:14 UTC by Jóhann B. Guðmundsson
Modified: 2012-04-03 18:57 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-03 18:57:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd service file for zabbix agent (191 bytes, text/plain)
2011-07-08 23:17 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix server mysql (197 bytes, text/plain)
2011-07-08 23:18 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix server pgsql (197 bytes, text/plain)
2011-07-08 23:18 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix server sqlite3 (200 bytes, text/plain)
2011-07-08 23:19 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix proxy mysql (200 bytes, text/plain)
2011-07-08 23:20 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix proxy pgsql (200 bytes, text/plain)
2011-07-08 23:21 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for zabbix proxy sqlite3 (204 bytes, text/plain)
2011-07-08 23:23 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2011-07-08 23:14:51 UTC
Description of problem:

https://fedoraproject.org/wiki/Features/SysVtoSystemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2011-07-08 23:17:24 UTC
Created attachment 512004 [details]
Native systemd service file for zabbix agent

Comment 2 Jóhann B. Guðmundsson 2011-07-08 23:18:07 UTC
Created attachment 512005 [details]
Native systemd service file for zabbix server mysql

Comment 3 Jóhann B. Guðmundsson 2011-07-08 23:18:52 UTC
Created attachment 512006 [details]
Native systemd service file for zabbix server pgsql

Comment 4 Jóhann B. Guðmundsson 2011-07-08 23:19:48 UTC
Created attachment 512007 [details]
Native systemd service file for zabbix server sqlite3

Comment 5 Jóhann B. Guðmundsson 2011-07-08 23:20:49 UTC
Created attachment 512009 [details]
Native systemd service file for zabbix proxy mysql

Comment 6 Jóhann B. Guðmundsson 2011-07-08 23:21:47 UTC
Created attachment 512010 [details]
Native systemd service file for zabbix proxy pgsql

Comment 7 Jóhann B. Guðmundsson 2011-07-08 23:23:17 UTC
Created attachment 512011 [details]
Native systemd service file for zabbix proxy sqlite3

Comment 8 Jóhann B. Guðmundsson 2011-07-08 23:38:30 UTC
I would like to recommend that the proxy and server conf be split into spesific settings conf file to their relevant type for example .

zabbix server sqlite3 would be started with...

ExecStart=/usr/sbin/zabbix_server_sqlite3 -c /etc/zabbix/zabbix_server_sqlite3.conf 

and the configuration file tailored in the above example to sqlite3 server only

Same goes for the proxy agents

To keep the backwards compatability ( service zabbix-server start ) with the proxy and server agent you will need to create a symbolic link at their install time like so..

Continuing with sqlite3 example

For zabbit server sqlite3 it would be

ln -s /lib/systemd/system/zabbix-server-sqlite3.service /lib/systemd/system/zabbix-server.service 

For zabbit proxy sqlite3 it would be

ln -s /lib/systemd/system/zabbix-proxy-sqlite3.service /lib/systemd/system/zabbix-proxy.service

https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd
https://fedoraproject.org/wiki/Packaging:Tmpfiles.d

Comment 9 Orion Poplawski 2011-11-21 19:17:05 UTC
We really need to get this stuff in place ASAP.  Currently on F16 this causes zabbix-server to fail to start because it gets started before the database.

Comment 10 Jóhann B. Guðmundsson 2011-11-21 19:56:03 UTC
Note that in F16 the window to provide native systemd unit files has passed thus requiring an exception from fesco should it be introduced to the distribution via update anyway regarding your problem just add the relevant dbfoo.service to the After= line in the relevant unit file and that unit will be started after the relevant db has started...

Comment 11 Orion Poplawski 2011-11-21 20:11:42 UTC
As a workaround, I copied /lib/systemd/system/mysqld.service to /etc/systemd/system/ and added:

Before=zabbix-server.service


Note You need to log in before you can comment on or make changes to this bug.