Bug 720100 - Cluster nodes will not communicate if multicast address is specified
Cluster nodes will not communicate if multicast address is specified
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cluster (Show other bugs)
6.1
All All
urgent Severity urgent
: rc
: ---
Assigned To: Fabio Massimo Di Nitto
Cluster QE
: Regression, ZStream
: 741345 (view as bug list)
Depends On: 713977
Blocks:
  Show dependency treegraph
 
Reported: 2011-07-09 06:44 EDT by Ken Reilly
Modified: 2011-09-26 14:00 EDT (History)
16 users (show)

See Also:
Fixed In Version: cluster-3.0.12-41.el6_1.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-07-19 06:46:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 5 Fabio Massimo Di Nitto 2011-07-11 04:11:32 EDT
Unit test results:

with unpatched cman-3.0.12-41.el6.x86_64

<cluster name="fabbione" config_version="1" >
  <logging debug="on"/>
  <cman>
   <multicast addr="239.192.224.34"/>
  </cman>
  <clusternodes>
[snip]

[root@rhel6-node2 ~]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   X      0                        rhel6-node1
   2   M     16   2011-07-11 10:07:24  rhel6-node2

With patched cman-3.0.12-41.el6_1.1.x86_64

[root@rhel6-node2 ~]# cman_tool nodes
Node  Sts   Inc   Joined               Name
   1   M     28   2011-07-11 10:09:48  rhel6-node1
   2   M     28   2011-07-11 10:09:48  rhel6-node2

nodes are now joining correctly.

[root@rhel6-node2 ~]# cman_tool status
Version: 6.2.0
Config Version: 1
Cluster Name: fabbione
Cluster Id: 17126
Cluster Member: Yes
Cluster Generation: 28
Membership state: Cluster-Member
Nodes: 2
Expected votes: 2
Total votes: 2
Node votes: 1
Quorum: 2  
Active subsystems: 1
Flags: 
Ports Bound: 0  
Node name: rhel6-node2
Node ID: 2
Multicast addresses: 239.192.224.34 
Node addresses: 192.168.2.66 

also verified that requested mcast address is in use.

[root@rhel6-node2 ~]# corosync-objctl |grep ttl
[root@rhel6-node2 ~]# 

lack of ttl in cluster.conf does not add a ttl=0 entry and leaves the default
from corosync as expected.
Comment 8 errata-xmlrpc 2011-07-19 06:46:57 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2011-0958.html
Comment 9 Fabio Massimo Di Nitto 2011-09-26 14:00:36 EDT
*** Bug 741345 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.