Bug 72019 - Linux rescue mounts the wrong root when several are detected
Linux rescue mounts the wrong root when several are detected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-08-20 15:13 EDT by Need Real Name
Modified: 2007-04-18 12:45 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-22 12:53:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2002-08-20 15:13:01 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.79 [en]C-CCK-MCD   (Windows NT 5.0; U)

Description of problem:
When using 'linux rescue', system will search for all linux partitions. It then prompts the user for the root system that should be 
mounted in /mnt/sysimage.

Whatever the choice, the first one is always mounted in /mnt/sysimage

I have two disks, one with root at /dev/hda7, another one (the one I tried to fix) in /dev/hdb2. System detects the two, asks me 
which one I want to use, I select hdb2, and find out that /dev/hda7 is mounted in /mnt/sysimage. Tried several times, always got the 
same result. I can mount hdb2 in any other mount point though

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Have several root partitions on different disks
2. Linux rescue disk
3. Select anything but the first 'root'

	

Actual Results:  The first root is always mounted, whatever the choice in #3

Expected Results:  The selected partition should be mounted in /mnt/sysimage

Additional info:
Comment 1 Michael Fulbright 2002-10-03 17:22:08 EDT
Works for me with Red Hat Linux 8.0.
Comment 2 Michael Fulbright 2002-12-20 12:38:25 EST
Time tracking values updated

Note You need to log in before you can comment on or make changes to this bug.