Bug 72020 - Clock applet cause panel crash on Laptop
Summary: Clock applet cause panel crash on Laptop
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Public Beta
Classification: Retired
Component: gnome-applets   
(Show other bugs)
Version: null
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 67218
TreeView+ depends on / blocked
 
Reported: 2002-08-20 19:16 UTC by Daryll
Modified: 2007-04-18 16:45 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-08-24 19:48:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daryll 2002-08-20 19:16:34 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
On my ThinkPad A20p, loading the clock applet in the panel will cause the panel
to crash

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Get a ThinkPad A20p
2. Login to X
3. Add the clock applet to the panel
	

Actual Results:  The panel crashes. The session manager then restarts the panel
forever. (See gnome-session bug)

Expected Results:  A clock applet runs in the panel

Additional info:

Comment 1 Havoc Pennington 2002-08-20 19:23:38 UTC
This just has to be thinkpad-specific somehow, as there are no other reports.

I'm not sure how to go about debugging it...

Comment 2 petrosyan 2002-08-20 19:48:05 UTC
works fine on ThinkPad T20

Comment 3 Daryll 2002-08-20 19:57:11 UTC
Is it possible to run the clock outside the panel so I could get useful
debugging information from it?


Comment 4 Havoc Pennington 2002-08-20 20:17:01 UTC
No, the clock is a dlopen() module loaded by the panel.
It is in the gnome-panel RPM though - 
If you rebuild the rpm with 
something like "rpm --define "optflags -g" -ba gnome-panel.spec" you would 
get a panel RPM with debug symbols.

Comment 5 Daryll 2002-08-24 19:48:28 UTC
I did a full install on the laptop instead of an upgrade and this problem went
away. I was having a bunch of odd gtk problems, so maybe there was a bad library
somewhere even though I had removed /usr/local/lib.

Comment 6 Brent Fox 2002-10-16 20:04:57 UTC
Ok, I'm going to close this as 'worksforme' since we have been unable to
duplicate this and since it's no longer happening for you.  It sounds like your
machine was in a weird state to begin with, so the chances of reproducing it are
pretty slim.

If you see the behavior again, please reopen this bug report.


Note You need to log in before you can comment on or make changes to this bug.