Bug 72023 - Toshiba Libretto 70CT won't execve
Toshiba Libretto 70CT won't execve
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
i586 Linux
medium Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2002-08-20 15:36 EDT by Brian M. Sutin
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2004-09-30 11:39:51 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Brian M. Sutin 2002-08-20 15:36:15 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.9-34smp i686)

Description of problem:
On a Toshiba Libretto 70CT, the 2.4.18-3 kernel boots up until freeing
the extra kernel memory.  After this, the execve to /sbin/init returns
success, but /sbin/init does not run.

Long Version:

The Toshiba Libretto 70CT has a 586 with MMX processor and 32MB of
memory.  It runs vanilla Redhat 6.2 fine.  It will not run Redhat 7.0 
or Redhat 7.3 (2.4.18-3), so the bug has existed for quite some time.  
The problem is that, on boot, I see:

    ...previous stuff...
    Freeing unused kernel memory: (some number)
    ...hangs forever here...

I tried having the kernel run the shell instead, but that did not work
either.  I also recompiled /sbin/init to print out a message to stderr
first off, but nothing appeared.  Putting the disk into another 686
machine runs fine.

I recompiled the kernel and started adding printk debugging statements.
I found that search_binary_handler() (from fs/exec.c) returns success.
At this point it is clear to me that I am not going to get any farther
with printk statements.

I also tried to make an a.out executable (rather than an ELF), but the
ld in Redhat is not compiled to create one, and I was unable to figure
out how to configure the recompile of ld to make it do so.  If someone
could send me an a.out-style executable of some sort, that would be the
next obvious test.

My info:

Brian Sutin
I will be out of town from 2002-08-21 to 2002-08-29.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. happens every boot-up

Additional info:
Comment 1 Bugzilla owner 2004-09-30 11:39:51 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.