Bug 72024 - sensors-detect internal error
sensors-detect internal error
Product: Red Hat Linux
Classification: Retired
Component: lm_sensors (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2002-08-20 15:37 EDT by Markku Kolkka
Modified: 2015-03-04 20:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-10-01 17:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
script of sensors-detect run (6.52 KB, text/plain)
2002-08-20 15:38 EDT, Markku Kolkka
no flags Details

  None (edit)
Description Markku Kolkka 2002-08-20 15:37:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020809

Description of problem:
When running sensors-detect on ECS K7S5A motherboard, the ISA bus scan gives
several error messages: "Character in "C" format wrapped at
/usr/sbin/sensors-detect line 963." and fails to detect the ITE8705F chip on the

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1.run sensors-detect
2.answer "YES" to question "Do you want to scan the ISA bus?"

Actual Results:  multiple errors on line 963, sensor chip not detected

Expected Results:  ITE8705 chip detected.

Additional info:

This worked on Limbo2.
Comment 1 Markku Kolkka 2002-08-20 15:38:08 EDT
Created attachment 71664 [details]
script of sensors-detect run
Comment 2 Joachim Frieben 2002-08-20 17:40:25 EDT
The same happened in the case of my PR440FX based dual Pentium Pro system. The
hardware sensor is some LM78 device. "sensors-detect" fails to detect the latter
whereas this worked at least for Red Hat Linux 7.2 and 7.3. However, inserting
the required modules (the same as in the past) by hand is possible (i2c-isa,
lm78). The "sensors" command itself works properly then. It is thus solely a
problem of "sensors-detect". The kernel support is functional.
Comment 3 Need Real Name 2002-09-14 18:33:39 EDT
There is a work around "patch" to the perl code that seems to fix things;
however, it still begs the question of what changed to cause the actual problem.
The file in question is called "sensors-detect" (located in the prog/detect
subdirectory of the lm_sensors source tree).

Here is a cvs diff from the lm_sensors cvs tree:

<   my $towrite = pack "C", $_[1];
>   my $towrite = pack "C", ($_[1] & 0xff);

Note, your line number may vary. 1075 is based on the cvs tree for lm_sensors
which I pulled (I have an a7v333 mobo that required the latest code). For null
beta 3, the line number is 1068...

Because the "broken" version is present in the lm_sensors cvs tree, I'm going to
speculate that the problem may have to do with perl, not the script. The value
that the "pack" function is complaining about is 0xFFFFFF80. I'm guessing that
it didn't use to be sign extended and now it is ?!?

Hope this helps...
Comment 4 Markku Kolkka 2002-10-01 17:00:55 EDT
Identical error happens in clean install of RHL8.0 (Psyche)
Comment 5 Phil Knirsch 2002-11-29 07:56:15 EST
I've updated to latest upstream version 2.6.5, but that still contained that
bug, so i fixed it in the latest rawhide build which is based on 2.6.5, too.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.